2

I am following this thread to enable my samsung android phone to do usb to ethernet communication

http://forum.xda-developers.com/showthread.php?t=2039886

I copied the smsc75xx.ko generated by the user Brandi into system/lib/modules folder. But when i tried to do insmod or modprobe to load the driver, this is what i get

root@android:/system/lib/modules # insmod smsc75xx.ko insmod: can't insert 'smsc75xx.ko': invalid module format

uname -r returns the following kernel version

3.0.8-perf-T769UVLH5-CL990184

Can you please help me compile for this kernel version? or suggest alternative paths to solve this issue.

I am completely new to android world and would appreciate step by step instructions with examples.

Best Regards,

  • your link is invalid. there are "...." in the url and results in a 404. – Ryan Conrad Dec 26 '14 at 16:31
1

You are trying to load a kernel module (noticeable at the .ko extension) as a software module (typically .jar or .so) Those .ko modules have to be compiled together with the kernel. You can't load them with a command, they have to be loaded by the kernel. If your kernel supports that module, then copying and rebooting is enough and the module should load and run. If it doesn't do so then you need a custom kernel with that module already built in.

  • Any idea where do i find the source code for kernel 3.0.8-perf-T769UVLH5-CL990184 and the steps needed to compile the source code against this kernel.Thanks for your reply. – user2979872 Dec 26 '14 at 20:41
  • If the device manufacturer himself hasn't published the sources or you can't find them, then there might be a custom kernel on xda-developers for your device with sources on eg. GitHub. If you're lucky then there might also be a tutorial on how to compile a custom kernel for your device. I don't own that device and also never tried to compile a custom kernel so you may want to ask some users on xda about that module. – GiantTree Dec 26 '14 at 20:45
  • where can i find the tool chain for this kernel 3.0.8-perf-T769UVLH5-CL990184 ? – user2979872 Dec 28 '14 at 18:28
  • This guide may help you out to build and compile your own kernel as I don't know what device you are searching the sources for: forum.xda-developers.com/showthread.php?t=2152819 – GiantTree Dec 28 '14 at 18:32
  • Hi GiantTree. Here is the device information. samsung galaxy S blaze-4g sgh-t769, android version = 4.04, Basedband version = T769UVMB1, Kernel version=3.0.8-perf-T769ULVH5-CL990184 – user2979872 Dec 28 '14 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.