I had installed link2sd plus and created link for the Gmail app, so that Gmail app is completely moved to the SD card 2nd partition.

The SD card then failed, I had to replace the SD card. After replacing the SD card, all the applications that were "linked" to the SD card did not work (of course). I had to re-install all the apps.

Some of the apps could not be installed, the error message was "Insufficient storage available". I figured that there were some apps like "com.google.....", which was listed in the Apps Settings menu (with 0.0B). I deleted such apps (for ex: com.google.android.keep), and then was able to install the corresponding apps (ex: Google Keep).

However, I am not able to install Gmail, which always shows "Insufficient storage available". I did "adb shell pm list packages" and do not find any package like "com.google.android.gm". Storage space is not an issue, there is sufficient space.

Any help allowing me to install Gmail will be appreciated!

Note: It is android 4.4.2 custom rom, found at http://forum.xda-developers.com/micromax-a116/development/discovery-rom-micromax-a116-t2863476 on Micromax A116 device

  • 1
    Glad to see the issue solved. A hint, though: pm list packages has a specific parameter: -u: Also include uninstalled packages. Might prove helpful in such cases ;)
    – Izzy
    Commented Dec 26, 2014 at 20:18

1 Answer 1


There are leftovers from all apps you moved to that SD card. You have to uninstall those apps manually (even though they are not existing anymore) which deletes all those leftovers. Then you are able to reinstall those apps again.

  • How do I delete those leftovers? How I do uninstall those apps manually (even though they are not existing anymore)? -- I have looked at the list in PlayStore -> My Apps and Settings -> Apps and adb pm list packages. I don't see gmail anywhere.
    – rsmoorthy
    Commented Dec 26, 2014 at 17:46
  • 1
    In your settings app there should be apps named like com.google.android.gmail. Those can be uninstalled and all leftovers are deleted. If it doesn't work you have to manually search for the folders in /data/data/ and delete them. Also there might be some libs leftover which you have to delete as well. They should be inside /data/app-lib but I assume they are all invisible as for me they are.
    – GiantTree
    Commented Dec 26, 2014 at 17:50
  • Wonderful. I saw the "soft-link files" in /data/data (which were the earlier leftovers - pointing to wrong location). I deleted it and that solved the problem. Thanks! (I did not know that the files were in /data/data, but I was looking at /system)
    – rsmoorthy
    Commented Dec 26, 2014 at 18:02
  • Nice that I could help you. :)
    – GiantTree
    Commented Dec 26, 2014 at 18:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .