0

My Asus ME302C tablet was giving charging problem lately and is completely dead now and not starting up. Around 5 days back, its charging got stuck at 55% and it never went ahead even after charging for 10 hours. I used it and then charged again and this time it charged few percentages and then stuck at 15%. My son then completely drained it out and the tablet powered off. I charged it overnight (the screen showed the battery symbol suggesting it is charging) but I was not able to start it.

I searched on internet and tried various options like: - Removing battery connector (by opening up the tablet) - Tickle charge, charging from PC usb port, phone charger. - Pressing power on button for long time.

None of it worked. Every time i power on my tablet, it shows initial screen which says "Intel Inside" and then blacks out and shows battery symbol with indicators moving up/down as if it is charging.

I have charged it for long time now around 20-24 hours, but still same issues.

Any idea, whats wrong here: - Is my battery dead or tablet OS is corrupted? - Whats are the steps to go to Android recovery screen? Not sure if i can reach that screen considering it is not powering up.

I am out of warranty now as it started giving problem exactly after one year.

Thanks, Ripan

  • Looks like a dead battery – Suncatcher Apr 11 '18 at 4:48
1

I had the same problem and discovered the problem is the digitizer board which the USB is attached to. I found one on eBay for $60 dollars and like magic, in twenty minutes it went from 80 to 100 percent while it was in use.

Out of desperation to fix my slow charging problem, I scoured the internet and one solution kept presenting itself, it's a hardware problem with the charging port. So I had planned to buy a new charging port and found them for under $7 on eBay. I don't solder very well, so I was dreading this process and then quite by accident I found the digitizer board which included a charging port. I was stoked, no soldering. It worked like a charm. You can save yourself some money if you can solder by just buying the port or else get a digitizer board. The part no is CL-2E241819.

0

It sounds like a hardware problem. A corrupt system would not result in your tablet instantly powering off. Your tablet is likely not getting charged (although it may be receiving power from the charger, it may be charging very slowly).

  • Try different charging cables and different wall adapters. There may be loose wiring in one or the other.

  • Check the charger port and see if there is any damage. There is likely to be undetectable damage as well, especially if you often move the charger cable around while it's charging (eg. resting on the charging wire, etc.).

  • I have already tried different cables, phone charger, different wall adapter, PC usb port but nothing worked. – Ripan Dec 27 '14 at 2:45
  • My old phone has a similar problem where it doesn't charge. Sometimes if I leave it on the charger for a few days, it will have a bit of power to turn on, but not much after that. All I know is that it is a hardware problem with the device, and it needs replaced. – LyricWulf Dec 28 '14 at 0:44
0

I have had similar high power drain/not charging properly/poor battery performance issues with my own ASUS ME302C Tablet over the past few days as well and I noticed by looking at the Battery performance graph under Settings > Battery that the Wi-Fi was never turning itself off when the Tablet was in sleep mode even though I had set it up long ago to always turn off when asleep.

This problem has only started up in the past few days so I don't know (yet) if it's as a result of some recent software update/change made to the Tablet from Asus. To further complicate my own situation, I noticed during my investigation of this issue that the Asus charger that was supplied with the Tablet seems to have developed an intermittent fault where it won't charge at various times depending upon how the USB cable is positioned when plugged into it. It looks like a faulty electrical joint inside the USB socket on the body of the charger itself.

So having also gotten that 'red-herring' out of the way by using another USB charger that I have here, I then found out after lots of mucking around and trying out different things that I finally managed to definitely improve matters by:

  1. Going into Settings > Asus Customized Settings and unchecking 'Use Asus Quick Setting', then
  2. Going back into Settings > Power management > Power Saver and turned 'Smart saving' off, then
  3. Going down that same page to Performance mode > Power configuration > Keep Wi-Fi on during sleep and selected 'Never'.

I then rebooted the Tablet Off and On again before quickly turning off the screen by momentarily pressing the Power Button again and then immediately connected it to the charger and gave it an 8 hour long charge which has now restored the Battery state back to 92%.

When I looked again at the Battery performance graph after doing these Settings changes and this charging cycle I noticed that this time the Wi-Fi has indeed turned itself off whilst the Tablet is asleep just as it should have been doing all along. Don't you just -love- software controlled hardware...! :-)

Anyway, I hope that my workaround as described above helps you out of your predicament.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.