I am installing Cyanogen Mod 10.2.1 on my Sony Xperia Z (yuga).

I followed all instructions exactly given on Installing CM Mod.

But after following the steps and clicking on Reboot system now in CWM-based Recovery, my device got stuck into a boot loop.

I tried all possible solution that I found but none worked -

Tried command adb reboot recovery and reflashing rom

Tried wiping cache partitions and dalvik cache

Tried reading this general help article

Please help in figuring out how to exit this loop and boot into Cyanogen Mod or Android. Please remember that I have Xperia Z and I cannot take out the batteries.

  • This usually happens for 1 of 2 reasons. 1: Are you sure you installed the correct CyanogenMod specifically for your device? 2: Did you wipe user data and cache before (or after) installing CyanogenMod via CWM? Step #7 is the important one in the instructions that you posted. – Ryan Conrad Jan 2 '15 at 2:42
  • Yes I installed the specific version made for my device and I also followed the step 7 exactly as given... – Confuse Jan 5 '15 at 14:07

This seems to be a problem created by a failed installation of CyanogenMod.

Please make sure you have read the notes on the CM-Wiki:

Note:

On 2011 models, the kernel will not update when flashed in recovery, so the kernel must be >updated via fastboot every time you flash a new build of CyanogenMod.

As far as I know you should be able to exit the loop by long pressing the power button until the screen goes black.
Also I suggest you install CM11 as Android 4.4 has far more support by the community than 4.1-4.3.

Before installing any new rom I would consider installing a stock rom to flash all possibly missing files and then begin to flash everything again (recovery, rom, kernel etc. in that order)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.