0

I have a asus tablet TF300T and I am trying to flash CM11 rom. I am following procedure from official CM pages http://wiki.cyanogenmod.org/w/Install_CM_for_tf300t, but I am stuck with flashing custom recovery (TWRP or CWM) using fastboot

I have switched to bootloader using

adb -d reboot-bootloader

I see RCK, android and wipe data icons but no USB icon which should be the one which I need to choose.

I tried to load custom recovery by following commands:

$ fastboot erase recovery
erasing 'recovery'...
OKAY [  1.905s]
finished. total time: 1.909s

$ fastboot flash recovery openrecovery-twrp-2.8.3.0-tf300t.blob
sending 'recovery' (6838 KB)...
OKAY [  2.617s]
writing 'recovery'...
FAILED (remote: (InvalidState))
finished. total time: 5.049s

or

$ fastboot flash recovery recovery-jb.img
sending 'recovery' (5644 KB)...
OKAY [  1.601s]
writing 'recovery'...
FAILED (remote: (InvalidState))
finished. total time: 4.488s

Tablet is running on 4.2.1 android with WW_epad-10.6.1.27.5-20130902 bootloader. It has been unlocked using official Unlock_v8.apk from asus pages. Am I missing something? Is there any other way, how to flash own recovery?

  • After you rebooted to bootloader, try this : unplug USB cord from device then reinsert. Should re-acknowledge the connection on the device. – HasH_BrowN Dec 28 '14 at 8:12
  • It does nothing. I have bootloader version, "Key driver not found.. Booting OS" and "Starting Fastbot USB download protocol" messages on the screen all the time. Nothing has been changed by plugging and unplugging. – Jan Stanicek Dec 30 '14 at 8:37
0

I probably found the cause of this issue. It seems that device was not properly unlocked. Despite Unlocker_v8.log file which said that device has been unlocked it wasn't.

The unlock app v8 from official asus support pages did not work for me. I tried entire process (link is in my very first message) but tried unlocker v7 which is the second latest.

I passed password verification against my gmail account (it was blocked due to security reasons on gmail server) and device was properly unlocked.

Calling

fastboot flash recovery openrecovery-twrp-2.8.3.0-tf300t.blob

from fastboot mode was successful without any errors and the rest of procedure also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.