2

When I connected my XT1033 (Moto G) to my computer in MTP mode, I was unable to access the contents of the internal storage in write mode. I was unable to create any folders, delete files, rename etc.

As part of trouble shooting, I attempted to connect XT1022 (Moto E) to the same port in MTP mode, I was able to access the internal storage and its SD card normally.

Puzzled with this behaviour, I connected my XT1033 again but this time in PTP mode and I was able to access DCIM folder normally.

I tried the same with another Samsung Galaxy Duos phone and it too worked properly.

When I attempted to create a folder in Computer\XT1033\Internal storage\Download in my XT1033 (in PTP mode) I get the following error:

The new folder could not be created in this location. The device has either stopped responding or has been disconnected

I am able to connect to the device thorough ADB and tested the following:

shell@falcon_umtsds:/ $ cd sdcard
cd sdcard
shell@falcon_umtsds:/sdcard $ ls -la
ls -la
....
....
drwxrwx--- root     sdcard_r          2014-12-28 18:50 Download
....
....

I was even able to create folders through ADB console and even push files:

127|shell@falcon_umtsds:/sdcard $ ls test
ls test
test: No such file or directory
1|shell@falcon_umtsds:/sdcard $ mkdir test
mkdir test
shell@falcon_umtsds:/sdcard $ ls test
ls test
shell@falcon_umtsds:/sdcard $ cd test
cd test
shell@falcon_umtsds:/sdcard/test $ ls
ls
shell@falcon_umtsds:/sdcard/test $ exit
exit   

Any idea what could be wrong or what should I suspect next?

Environment: XT1033 (Moto G) rooted, running stock 4.4.4 Computer running Windows 7 x64.

Update: If USB debugging is switched off, I am able to read and write normally in phone's internal storage. If it is switched on, the internal storage becomes read-only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.