0

Whenever I try to turn on my WiFi, it shows Turning Wi-Fi on but automatically turns off. I have not recently installed any app, and earlier it used to work absolutely fine. I even tried doing a factory reset, but it's still not working. Not sure whether it's a software or hardware issue.

I am using Micromax Canvas A116 phone running Android 4.2.1

0

Go to settings > wireless connections > wifi > more > advanced Make sure wifi timer is off and that 'Keep wifi on while on standby' is on. Try it again. If this doesn't work go to your phone. And dial *#0011#. This is a hidden setting number so it opens a menu, it ain't calling anybody so don't worry about your money. Press more > wifi > wifi powermode off. If that doesn't work either, it's probably a hardware failure. It might be malware as well, and then ressetting your phone doesn't work. The malware will be in your system files so you need to reinstall your software completely. This loses warranty so I advice you to go to a nearby phoneshop and ask them if they want to check your wifi and repair it. They mighr even reinstall your software because if you do it yourself you lose warranty.

Have a nice day,

  • I tried all these and a lot more. I even flashed my ROM as my warranty period was long gone, but still it does not work. Seems like a hardware issue. Thanks for answering btw. – coder_r Jan 2 '15 at 9:43
0

First of all, this topic is long dead, but still couldnt stop myself from posting this, as this saved a hell lot of time & nuisance, for me...

all in anticipation of saving ones phone from rooting>deleting>installing all apps> and have pressure situation of whether all this will work or not

by just getting back to date from 10-12-2015 to 07-12-2015, in my case to be precise... VOILAA!!! everything back to normal ~~~ and here i am sharing my facts to help all those who are facing this ridiculous problem.

p.s. had been searching throughout the net for the solutionand found some interesting details... would love to share for others (if they can be of any help) ... factory formating/ soft or hard resetting wont work, so as the phone rebooting will also be noteffective ... setting back clock (manuallly) worked like a charm for me (my mobile lenovo Vibe X, carrier Vodafone) ... this problem arose, in my case, when i updated certain apps 5or6 OTA on Google Play Store (mainly Google inbuilt ones) ~~~ for others sufferers as i came to read through their posts >>> when they updated their handsets (for any updates... irrespective of any app) their wifi settings got disturbed causing the wifi to lock while initialising, not allowing the user to switch On or OFF, just displaying the scree n WIFI turning ON/Scanning/Starting/Searching/etc. ... a common solution suggested by many (which even i was going to try ~ if above hadn't work) was

solve it by deleting /data/misc/wifi/wpa_supplicant.conf. It will reset all your saved networks. have your phone rooted and delete the file through a root explorer or you can remove it via ADB (adb shell rm -r /data/misc/wifi/wpa_supplicant.conf. I'm not sure).

You may backup it before, then open with a text reader to see your saved passwords.<<<

on many forums, this was the common solution accepted as the only chance to get rid of the problem.

  • 1
    There is no such thing as a dead topic on SE network. – SarpSTA Feb 10 '16 at 16:42
0

This solved the problem for me: In Wi-fi settings > Advanced, turn off 'Always allow scanning'. (This is the setting that allows applications to scan for Wi-Fi networks even when Wi-Fi is off).

protected by Community Apr 14 '17 at 9:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.