3

I just rooted my Moto G 2014 XT1064 running 5.0.1.

I used this article to do the root process: http://maktechblog.com/how-to-unlock-the-bootloader-and-root-the-motorola-moto-g-2nd-gen/#Root Which evolved unlocking the bootloader (which caused data to be erased, of course), installing TWRP, then copying SuperSU.zip over adb, then going back to TWRP recovery and installing SuperSU through TWRP.

Since then, /sdcard seems to be acting like its mounted as read only. I cannot seem to get anything written to it. I've tried to adb push files to /sdcard, but I keep getting the same "Permission denied" error. Taking screenshots don't work either, I get a "Couldn't capture screenshot" error. And I've also noticed the Twitter app is unable to display profile pictures nor pictures inside of tweets.

I've tried numerous things, but I'm stumped.

I've tried to see if its mounted as read only. Via adb shell, and su to get root, and mount to view the mounted file systems. Everything dealing with /sdcard, /storage/emulated/legacy, and /data/media are all mounted as rw (Read & Write, of course).

Remounting them doesn't produce any errors, but has no effect.

The file system for /sdcard seems to be just fine, as I can adb shell in, and use ls /sdcard/, from either regular shell or root. And via TWRP, it was able to successfully save a recovery.log to the /sdcard/ file system, indicating nothing should be preventing things from being written to the file system.

I am also unable to copy files to it via Windows, it tells me "Cannot copy [file name] ... The device has either stopped responding or has been disconnected", and OS X still doesn't seem to recognize it at all despite installing drivers from Motorola, which has happened before I rooted it.

What I found particularly weird is that I can download and install apps still. I installed a root checker app just after rooting it, and it worked, and I wanted to screenshot it, and then I noticed the issues happening.

And I've even tried a free app from Google Play which uses SuperUser permissions and attempts to fix the sdcard file system and make it mount right. Still, I am unable to write anything to it.

I've also tried to see if restarting adbd as root via the 'adb root' command would work, only to be disappointed because it doesn't work on production phones, despite my phone already being rooted.

I'm pretty new to android in general, including rooting, but I've definitely gotten a good feel for how it works, when I installed 5.0.1 onto it a few days ago (It came with 4.4.4 and didn't have an OTA update yet). But now I'm really confused about why this happened after I rooted, and after a bunch of googling to find nothing helpful, I have to ask here.

Any suggestions?

Edit: Just to be clear, Settings also reports I have 2.4 GB available space, and the file I am trying to copy over is far less than that.

  • I have the same issue. Is it solved ? – ransh Dec 29 '16 at 11:24
0

I don't know if it will solve your problem or not, because I never actually had issues "writing" to the sdcard, but apps seem to have problems sometimes. here is what I did.

I am suggesting this method because you said you use TWRP as your recovery.

Get the TWRP manager and open it.

If you don't have the version of BusyBox they use it will complain. I am not sure if it will work with any other version. I have CM12 installed, which comes with busybox, but the TWRP app complains, so I use the one they recommend. The one they use does update busybox (automatically if you have the pro).

It will then tell you that it can't write to the sdcard, and they can fix it. Click "yes" it will take you to the setting of the TWRP manager. Click on the option that says "Apply SD Card patch". This will reboot your phone.

enter image description here

Note that mine is disabled and says "Already applied or not needed". This is because I have ran the patch already.

  • Didn't seem to do much. I installed BusyBox and and TWRP manager, and TWRP manager didn't seem to report any issues with writing to sdcard. – dangered wolf Dec 31 '14 at 16:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.