3

I've updated my HTC Desire HD A9191 to Android 2.3.3 and now I don't know how to get rid off the spelling check (red dotted underline) when text messaging. The underlining isn't present when typing in Evernote's application, for example. It is strictly text-messaging issue.

There's no spelling-check option in message settings. I've tried turning on and off spelling check under Settings->Language & Keyboard->Touch Input->Text input->Spell correction and it didn't do anything either way. I don't have enabled neither 'Prediction' nor 'Word completion'. Google search didn't find anything about red dotted underline on Androids either.

Why would I want to disable spelling check? Androids don't support my locale the way they should (QWERTZ instead of QWERTY), so I'm forced to use German locale. Which is fine, I'd use English as a system language anyway. But the spelling check is underlining non-German words, which is obviously annoying to me as a non-German native speaker.

3

You can use an alternative SMS app, e.g. Handcent. I think the spell checking feature is probably HTC specific (AFAIK, HTC has their own SMS app).

1

go to: Settings->Language & Keyboard->Touch Input->International Keyboard , and uncheck all the languages EXCEPT the one that you're texting in.

  • 1
    the above doesn't work :( (at least on HTC Desire Z) – user7697 Sep 1 '11 at 14:27
  • 1
    This does not help if the language one is texting in is not recognized by the system. – Pit Nov 9 '11 at 9:16

protected by Community Sep 1 '11 at 14:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.