0

I've got an Xperia Z2 running CM11, and would like to switch to TWRP as my recovery. TWRP's website has the instructions I followed for this device.

It states that "if you install current CM10 and CM10.1 nightlies and flash TWRP to the FOTAKernel partition, you will be able to use TWRP instead of the CWM that normally comes in a CM boot image" (I'd be amazed if this worked for CM10 and not CM11?)

I have downloaded the 2.8 openrecovery***.img file to my sdcard, and followed the instructions -

adb root
adb shell dd if=/storage/sdcard1/FILENAME.img of=/dev/block/platform/msm_sdcc.1/by-name/FOTAKernel

adb output:

23828+0 records in
23828+0 records out
12199936 bytes transferred in 1.579 secs (7726368 bytes/sec)

So adb seems to think it worked, and dd seems to think it found something called "FOTAKernel" to overwrite.
Reboot to recovery, and no sign of TWRP, it still puts me into CWM. What am I doing wrong?

  • are you sure you have superuser permission? By design adb root command works in development builds only (ones with ro.debuggable=1) -from SO --- try 'su' – maxpesa Jan 2 '15 at 11:26
  • superuser definitely works. I'm using SuperSU 2.40 and tested it with terminal as well as over adb: in Terminal, "su" -> SuperSU requests permission -> whoami then gives "root" and allows r/w access to entire filing system including usually inaccessible files. (Also programs like Titanium Backup that need root would complain if su wasn't available). Over adb, "adb root" + "adb shell whoami" also returns "root". So I'm guessing root access isn't an issue..... or have I missed something? Just tried again and as before, straight into CWM, no sign of TWRP. – Stilez Jan 2 '15 at 18:48
  • try to flash it via fastboot, so we'll know if the problem comes from adb or your phone – maxpesa Jan 2 '15 at 23:16
  • ditto. Tried that too (in all variants Ive seen online: "fastboot flash boot FILE", "fastboot flash FOTAKernel FILE", "fastboot flash recovery FILE"). Same results each time. I should say that I have got TWRP to work - but only by flashing an entire "known good" boot.img which had been built by others and based on the stock rom. Haven't managed to find a "known good" non-stcock rom that has TWRP on this device. – Stilez Jan 3 '15 at 10:04
  • Huh, things are strange here. My last advice is to install clockworkmod ROM manager from the play store, if I remember correctly, the last time it had the option to install TWRP, see if that works – maxpesa Jan 3 '15 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.