11

I frequently use SMS shortcodes to get my account balance from my bank. I send a text message to the bank's short code (in this case, 728464), and my bank replies with a text message containing my current account balance. I've been doing this for a while now with no issues.

I recently switched phones (to a Nexus 6 running Android 5.0.1), and now when I send my text to 728464, I get an error (from my phone, not from the bank) saying that the short code I am texting is not valid. I noticed in the error that either Hangouts or Android seem to be prepending a "1" to the short code (see the screenshot). I'm guessing that this has something to do with it.

How can I prevent Hangouts from adding this "1" to my short code (which seems to be preventing me from sending the SMS)?

In case it's pertinent, I have imported all of my SMS conversations from my old phone using SMS Backup Restore app, and have selected Hangouts as my default SMS application.

enter image description here

  • First shot: Save all contact phone numbers in "full notation" (i.e. with country prefix) – but I don't use Hangouts at all. Maybe it has an option somewhere for the default country code which you could adjust? – Izzy Jan 2 '15 at 19:02
  • I tried all the suggestions to reach 66402 here in Germany -- messaging and creating a contact as 66402, +66402, +4966402, switching the default source account to carrier SMS, turning off "merged conversations" in settings, and enabling premium SMS (which was already "ask"). Totally unable to send 😞 – James B Aug 26 '15 at 18:53
  • FYI I sent the text immediately, without issue, after installing Messenger. It actually registered as the contact I'd created after specifying 66402 (no prefixes) as the recipient. In short: Hangouts is super, super broken. – James B Aug 26 '15 at 19:17
8

Save the shortcode number as +728464. Hangouts all think that +7 is the prefix, so it won't prepend the +1.

  • 1
    Yup it works, But its still annoying, so i have to create a contact for each short ode number i wanna text. – Elye M. Jan 12 '15 at 21:15
  • I created the contact with the +7801 and hangout replaced the 7 with a 1. So that didn't work. But when I create a contact with just 7801 and it worked! – mateuscb Apr 4 '15 at 17:27
  • 1
    +7 is Russia so isn't really a solution – abatishchev Apr 9 '16 at 22:37
3

I have found a solution that worked for me: Go to Settings -> SMS -> Default SMS Messaging Account

Then change it from you Google account into "SMS only account".

After doing that it no longer prepended the country code to my SMS contact number (no need for it to be saved as a contact).

  • This worked perfectly for me. Now I was able to send a text message to Viettel and have my 3G service activated. Thanks! – Jason McVetta Aug 8 '15 at 15:35
0

I've been having this issue too and discovered if I turn off "Show (Google Voice) SMS & voicemail in Hangouts" that this issue doesn't happen. As soon as I tick that back on, the problem comes back.

protected by Community Aug 3 '15 at 20:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.