1

I have a USB flash drive that has two connections, one USB and one micro USB. I have attached it to may phone but it won't mount. I have tried rooting and using other file browsers but nothing seems to help. Does anyone have any suggestions on how I could get the flash drive to mount. I have tried StickMount but that doesn't seem to work.

The flash drive looks something like this:

image of the flash drive

Edit: I have tried it in 2 other phones but no luck. I then tried it in my tablet and it worked perfectly. Can anyone explain why it would work in a tablet but not a phone.

  • Are you using an OTG cable or just plugging the micro usb flash drive straight into the phone? – Tim Wilkinson Jan 5 '15 at 13:45
  • @TimWilkinson See edit. – user87592 Jan 5 '15 at 13:49
  • @TimWilkinson I could try using a OTG cable if that helps. – user87592 Jan 5 '15 at 13:50
  • I cant imagine it would, but thats all i have ever used, also what size flash drive is it, 16, 32 or 64gb? – Tim Wilkinson Jan 5 '15 at 13:57
  • Its 16gb, I have tried the cable just now but no look. – user87592 Jan 5 '15 at 14:05
3
+100

The reason is that your phones does not support OTG cables, most android devices (70%) support OTG but some don't. The reason for this, is because your phone hasn't got the right hardware for it I have a tablet that doesnt support it and managed to get it to eventually working alright (It doesnt work in other apps, but you can copy the files at a fast speed using some applicatons that are built around this one) by using USB OTG Helper [root], Please let me know if this works for you
THIS REQUIRES ROOT ACCESS
Also you could try charging your phone to 100% and then trying again, If none of this works then it would be most likely because of your phone not supplying enough voltage to the drive, so you may need a external power supply

  • I have tried OTG helper but no luck so I have purchased a external power supply but still nothing. – user87592 Jan 10 '15 at 11:32
  • Then you dont have the right hardware in your phones, and the only way to fix this would be taking the phone apart and putting different hardware in. One last way of doing it would be to connect it to your tablet, share the root usb folder (On tablet) and then open it up on your phone – user86581 Jan 10 '15 at 15:34
  • Are you sure it is a hardware problem and there is nothing else i can do. Like editing or using a diffrent ROM. – user87592 Jan 10 '15 at 16:59
  • I am not 100% sure – user86581 Jan 10 '15 at 17:10
  • It is generally cheaper to use the same hardware across similar models of a phone. What usually is different is the software and in this case, quite possibly your phone's kernel does not support OTG. Having said that it is usually not easy to find the right kernel sources, compile it, create a new image of your phone and download this new image, whic would let the drive mount correctly... – nass Jan 12 '15 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy