3

After I got my phone restored from an nandroid backup, I found almost all apps cannot gain access to /sdcard/ (internal storage), including ES file manager, Z archiver and so on.

When any of these apps access /sdcard/, or any other equivalent folders like /storage/emulated/0, /storage/emulated/legacy, /storage/sdcard0, they only shows a blank directory, and I cannot create any file or folder.

When I try with the stock file manager (My files), it does show the files, but i cannot rename, edit, or create anything.

Android File manager is able to copy most of my files out. But It stucks when I try to create a folder or send something.

I tried to re-flash the same ROM again (which worked perfectly before), the issue remains. I have backed up important data from /sdcard/.

In terminal emulator, cd sdcard, ls gives opendir failed: permission denied. Then I tried su, ls shows the correct directory.

How should I fix it?

Extra: I found a new folder called knox-emulated in /storage which is not there before. External SD card (/storage/extSdCard) works fine.

Device Information: Samsung Galaxy Note 3, Android 4.4.2 Rooted, with a custom ROM modified based on the Stock ROM. Custom recovery installed.

  • Did you try setting SELinux to permissive? That should fix it. – Shayan May 2 at 18:37
0

Try moving your primary storage in settings.. go to apps scroll all the way down and change your storage from phone to sd storage and vice versa. And you should be able to access everything on sd card etc. ES file explorer is a great free app in case you couldn't get it by changing storage in setting

0

I ended up encrypting my SD card. And found that out when I typed SD in the search bar of my Android Galaxy J3. And it show Decrypt SD card. I tapped it and tapped Decrypt my SD card is back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.