25

I have used smart lock with trusted places since it arrived and it has been working fine. Without any noticable changes, it has stopped working. My location shows in maps as exactly where I am, but being at one of my trusted places still makes me type my pass key.

I have tried toggling location, accuracy, rebooted phone etc but with no luck.

Any ideas on how to fix this?

  • This started happening to both my wife and me at exactly the same time. Must be a bug with Play Services. – baynezy Mar 31 '15 at 18:15
3

It might have something to do with this issue: Issue #79735: Smart lock feature (trusted face/device) not working when screen is turned off using software screen off command (DevicePolicyManager.lockNow)

In short: Smart lock breaks when any app uses "soft power off", i.e. your screen is turned off by an app or in any way except the hardware button or a normal timeout.

Note that when this is the case the small pulsating circle around the lock symbol (at the bottom of the lock screen) is missing, since all smart lock variants are disabled (e.g. trusted faces also doesn't work anymore).

  • This looks "promising". I will accept for now :) thank you – chwi Mar 3 '15 at 6:47
  • 1
    I'm seeing this problem, although pressing the hardware power button does NOT fix it. The problem only began a few days ago. – Chris Mar 21 '15 at 23:00
  • This just started happening to me in the past month and my phone always screen-offs because of screen timeout or me pressing the power button. I don't have any apps that use soft power off, at least not intentionally... :-\ – dash-tom-bang Jul 28 '15 at 18:51
0

This might be an issue with your mobile data connection. Your phone may not receive the sufficient GPS signal to identify and trust the location. Try connecting to a wifi network when you are at a "Trusted Place" for better data connection. I have faced similar issue and works fine when I am connected to WiFi.

  • 2
    I am always on wifi on my trusted places. Tried turning if off as well but no success – chwi Jan 9 '15 at 14:53
  • I'm having the same problem, for the last week or so. It consistently doesn't function correctly at work, and it's a crap shoot at home. I'm connected to wifi in both places. – Asmor Mar 26 '15 at 21:41
  • I've always wished that it would use my wifi connection as a trusted place, alas this does not appear to be how it works as when I'm on my wifi it thinks I'm at a location other than the one I'm at! – dash-tom-bang Jul 28 '15 at 18:53
0

An ananomous poster sent me this;

Disable Android device management at settings/security and try smartlock again. If it works again you can even put device management back on

Guess he didn't want to sign up to register the answer? Can't confirm this since I won't have my phone before a couple of days

  • This does not fix it for me. Where I'm finding something that looks like what's described in the post is Settings->Security->Device Administrators (View or deactivate device administrators)->Android Device Manager (Allow Android Device Manager to lock or erase a lost device). With this unchecked I still get prompted for my unlock code. I've even set a location at my neighbor's, which worked in the past, but it does not work at this time either. – dash-tom-bang Jul 29 '15 at 1:21

protected by Community Mar 24 '15 at 13:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.