1

I'm having a problem similar to that described here: https://forums.openvpn.net/topic17851.html - namely I have a home OpenVPN server set-up that I can connect to with my Linux machines and with Android Kitkat, but when I tried to connect under Android Lollipop (with various Android OpenVPN apps), it doesn't work - I remain connected to my local network. Most of the OpenVPN apps I try, including OpenVPN Connect (the official app) just report successful connection (but then don't show any up/down activity beyond an initial blip) - even though they aren't really connecting me properly to the VPN. However, 'OpenVPN for Android' app additionally reports:

Route rejected by Android224.0.0.0/3 Bad LinkAddress params /224.0.0.0/3

Which is mentioned in the forum post linked above. I tried the solution suggested there (though, in fact my client-side .conf didn't have any "topology" entry - so I tried adding "topology net30"), but it didn't help.

Again, all of my other devices (Android Kitkat, Linux machines) can connect to the VPN without any difficulties or complaints. Is this some sort of Lollipop-specific glitch and is there any way round it?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.