I have a new HTC Desire S in the UK unlocked from Amazon running Android 2.3.3 and HTC Sense 2.1.

When I charge the phone the touchscreen is non responsive. I have tried changing Settings > Applications > Development > Stay Awake (screen will never sleep whilst charging) but this makes no difference.

The touch screen does not respond, whether the phone is dark, lit up looking for my lock pattern, or unlocked and on the home page.

If it is charging and I press the power button the screen will wake up, but still the touchscreen is disabled completely.

Hopefully I have been clear that this is not solved by the "stay awake" function (seen elsewhere).

So, in summary, when charging the touchscreen is completely disabled and changing the "stay awake" checkbox makes no difference.

Any other ideas welcome.


  • 1
    There have been occasional reports of trouble like that on assorted devices, more typical using mains chargers than PCs - presumably electrical noise interfering with the touchscreen. Out of curiosity, you might try the supplied mains charger or another PC. And one more test before you give up - if you hold the phone in your other hand, does it work? Some capacitive touchscreens seem to need a hand or something conductive behind the phone before they will reliably register touches on the front. Commented May 17, 2011 at 14:41
  • 1
    I've also run into this with one particular charger. I'd try a different charging method to see if that's it.
    – terry1769
    Commented May 18, 2011 at 14:35
  • 1
    Thanks for the advice on switching around the charging connection as a test. Should have thought of that test. The stock HTC wall plug and connection to a PC work fine. However, I bought a second charger with a cradle for a spare battery - this causes the lock out on the screen. I won't connect it to my phone anymore for fear of damage.
    – andrewfd
    Commented May 18, 2011 at 15:44
  • related: android.stackexchange.com/questions/12985/… Commented Jan 26, 2013 at 0:02

1 Answer 1


If you have a warranty I would use it as this sounds like malfunctioning hardware, not a software problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .