I soft bricked my colorfly g808 by following this guide (Japanese)


I didnt do it using adb shell but using a terminal emulator in the phone itself, so I don't have ADB debug mode enabled.

the file in question is


I need to set its permissions to "644"

I have access to adb sideload by pressing the volume key while booting while connected by USB.

I tried several tutorials for making a custom updater-script but I always get the message "Installation aborted." when I try to install it. I tried signed and unsigned, by the way.

Is it possible at all to create an update.zip for just setting a permission on a file? do I need an "update-binary" also present? (I tried including one from here http://pan.baidu.com/share/link?shareid=92493&uk=252038779 which I thought was targeted for my device)

My android version is 4.2.2... I think..

What I see in the computer:

$ adb sideload update-signed.zip 
loading: 'update-signed.zip'
sending: 'update-signed.zip'  100%  

What I see in the device:

Now send the package you want to apply 
to the device with "adb sideload <filename>"...
Installation aborted.

The "Installation aborted" appears right after I send the file. It looks like it doesn't even try to analyze it. I tried simplifying the script using just

ui_print("Next time don't forget to enable debug mode before playing with fire!");

(I'm taking care of leaving an empty line at the end also...)

The zip file I'm using: http://s000.tinyupload.com/index.php?file_id=79008422714753153826

Another trial: http://s000.tinyupload.com/index.php?file_id=00027545588116868142


Sure. Just put it in the updater-script which is usually located in META-INF/com/google/android/updater-script

Make sure your script mounts the data partition and executes something like this:

set_perm(0, 0, 0644, "/data/resource-cache/vendor@overlay@framework@framework-res.apk@idmap");

Not sure if the @ chars are not causing trouble in recovery though.

And yes, you need updater-script etc. in there.

| improve this answer | |
  • You mean I need "update-binary" there? – マルちゃん だよ Jan 10 '15 at 5:05
  • Not necessarily. If you look e.g. at the update-binary script from Superuser, it can also be just a shell script: link – kuleszdl Jan 13 '15 at 19:12
  • I'm fairly sure that ADB Sideload only works for packages that have a corresponding signature... You would need to flash it using a custom recovery. – Gadget Guru Dec 27 '18 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.