0

I am new to all of this, and I am having trouble with my Verizon Samsung Galaxy S4 SCH-I545. I am on a Mac, but can also run Windows 7 in VMware Fusion.

A couple days ago, I successfully rooted my phone, by flashing it with odin. Several days after that, I successfully installed Safestrap Recovery, but did not do anything with it. Then I tried flashing a ROM for TWRP, and thats where my troubles started.

When I rebooted my phone, it constantly got stuck at the Samsung Galaxy S4 screen.

I tried wipe data/factory reset and wipe cache partition, but to no avail.

I can boot into the stock recovery (Safestrap got removed when I wiped my phone), and I can boot into fastboot.

When I boot it into recovery, it says

E:failed to mount /system (Invalid argument)

Then I tried flashing the stock ROM with Odin and it kept failing. (I may have done this wrongly, because I did not get a PIT file with my Stock ROM download, and therefore had to use a different one that I found for the I545)

I also installed SDK tools for Mac, and used terminal to sideload a ROM, but once it hit 100%, my phone says

E: footer is wrong E: signature verification failed

So here I am now: Terminal will connect to my phone when I select Apply Update From ADB in recovery,

 adb devices - shows my phone
 fastboot devices - shows nothing
 adb shell - gives error 'closed'
 reboot bootloader - gives error 'closed'

I have tried using the following to fix the error 'closed' but again, to no avail.

 adb kill-server
 adb start-server
  • Have you tried to download the stock rom from xda developers forum or sammobile website? I had an soft brick with my S4 i9500 too and fixed it with stock rom downloaded from sammobile + odin make sure it is for you specific model – Freedo Jan 10 '15 at 20:33
  • Thanks for replying! Yes, I have tried that, and odin fails every single time. And when I try to reboot it into recovery afterward, my phone says "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again." I have tried changing the usb port, and taking the battery out when flashing it. The only tars that I have gotten to flash right now are an I545 NC Stock kernel, and an I545 NG6 Stock Kernel. If I reflash the NG6, the firmware upgrade message goes away and I can get back into recovery, but I am also back where I started, with the Galaxy s4 logo stuck on startup. – Josn Jan 10 '15 at 23:29
  • Did you checked if you have the lastest drivers installed to be sure? I would try on a windows pc and also try to flash the stock recovery and stock bootloader just to be sure maybe the safestrap recovery left corrupted files and its messing with the flashing process – Freedo Jan 10 '15 at 23:37
  • Ok, so I successfully flashed the stock recovery in Vmware fusion, and then tried flashing the Stock Rom from sammobile, but the stock rom failed. I will try it all on an actual windows PC hopefully within the next couple of days. But shouldn't flshing it work with the stock rom if it worked with the stock recovery, even though I am using Vmware? Also, Where can I find a stock bootloader? – Josn Jan 11 '15 at 5:09
  • I fixed it. I used this video, and just did it all with the S4 I545 Rom from sammobile. youtube.com/watch?v=KP9FS63s-HI – Josn Jan 12 '15 at 4:47
0

Whoa, hold the phone! Had this problem and thank God I didn't do factory reset. Have a Galaxy S4, my carrier is Sprint if that matters. It's rooted, otherwise stock. My fix, hope it works 4 u:

1) Pull battery, wait 10 secs, put it back in, don't turn it on. 2) Simultaneously press vol down, button below screen, and power. 3) When it powers up, immediately release only the power button, keep holding the other 2 for a few seconds.

Boot up normally and you're done, but backup your data now...

  • I've tried your suggestion and my device says "warning a custom OS can cause critical problems in phone and installed applications. If you want to install a custom OS press the volume up key. Otherwise, press the volume down key to cancel." Nothing gets resolved. – hortstu Oct 14 '18 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.