4

I have been searching the web and this website for information about the file systems supported by Android. I have not found anything though.

Since KitKat (Android 4.4), some changes have been applied regarding the access of the applications to the external SD cards. Many websites explain, pretty well, that this is due to Android offering read/write access control over the folders and FAT file system not offering this feature.

This is nice to know the cause but now I am interested in finding a solution. Not a workaround that involves an app or whatever, but I would like to know which file system I can format my sd card with and Android recognizes it. I vaguely read about EXT, but which version? Does Android work with EXT 3, 4?

By the way, I apologize if this has been asked, let me know the duplicate in that case.

  • Ext4 is supported in some versions (such as CM) but you want to use exFAT, since ext4 causes a permission hell. – mikky Jan 31 '15 at 23:53
2
+50

This limitation is not due to the FAT filesystem : Since 4.4, Android only lets a special user group write on the card.

Your card could be in NTFS, or EXT or whatever more, you'll have the same problem.

The only way to bypass this limitation is to root your device, and install some 3rd party apps/patchs, or manuallay edit some files.

  • When you say "manually edit your files", does it involve that I can manually edit even a folder to give writing rights to some specific application? Do you have any idea how to do that (e.g. is a user group identified by a package name)? – Vince Feb 7 '15 at 17:08
  • 1
    No. What I want to mean is that to bypass the limitation you can (once you're rooted) : - apply some patch or 3rd party app which make some automatic modifications (play.google.com/store/apps/details?id=nextapp.sdfix here for example) - edit the system files manually (which will be the same result of the patch, but a little more tricky) – egoz Feb 8 '15 at 9:50
0

Android supports multiple file systems. Your problem is root access, as 4.4 has further restricted application access to SD memory. Root your phone and your problem is solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.