Bought a second-hand Nexus 7, the 32 GB 2012 3G model with Android 4.4. I'm trying to install Kali Nethunter on it, but to do so I first need to unlock and root it. I followed the installation steps on nethunter.com. Right now I'm trying the same things after a factory reset, but to no avail so far. I also tried several USB cables, but mainly the OEM one. I could copy my whole music library onto it through MTP connection without any problem.

I disabled MTP and PTP, enabled dev mode and USB debugging. When I connect it I see "USB debugging enabled" in the notification area, but then it should show a pop-up asking me if it should pair the device with the PC, yet it shows no such thing.

I've tried this on Windows 8.1, XP and Ubuntu. All of them see the device. (I checked with the Device Manager and the lsusb command)

On Windows 8.1 I tried the solutions I found on other sites. (Some I even tried on XP, but I'm not sure which ones. The results were the same.)

  1. In the Device Mgr. installing it as a Generic USB Device (and a few similar options). It should be noted that there was supposed to be one option that Windows automatically finds compatible, but that option did not show up, it just listed all available options.
  2. Installing Google's USB drivers. I pointed Windows to the driver folder, but it did not recognize it.
  3. Connecting with MTP and then disabling it and reconnecting.

1 Answer 1


Ok, apparently a factory reset and using MTP fixed it. I'm not sure why or how, but USB debugging only connected when MTP was on, so I had to leave it on for the majority of the installation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .