Sometimes after I install new version of cm speaker volume is too low. Then I install another version and it is ok. I did some search and found this post (http://forum.xda-developers.com/showthread.php?t=2400231) describing how to fix that for Samsung.

The exact line I you need to edit is RX5 Digital Volume:1:65% but I did not find that one in my 'snd_soc_msm_2x' config file.

Any one could explain how to fix the volume for HTC One XL? I do not want to install any sw to make this work.

Currently I am running 11-20150104-nightly and the volume is very much too low. My snd_soc_msm_2x looks like


    'SLIM_0_RX Channels':0:eek:ne
    'RX3 MIX1 INP1':0:RX1
    'LINEOUT1 DAC Switch':1:1
    'LINEOUT3 DAC Switch':1:1
    'LINEOUT1 Volume':1:73
    'LINEOUT3 Volume':1:73
    'RX3 Digital Volume':1:73
    'RX4 Digital Volume':1:73
    'SPK AMP EN Switch':1:1

The original steps how to fix it from the link above are....


Navigate to device folders.
Open "etc" folder.
Open "snd_soc_msm" folder.
Open file "snd_soc_msm_2x" file with editor.
Look for the following section below, it is at 41% using ES editor.

Name "Speaker"
Comment "Speaker Rx device"

'PRI_RX Channels':0:Two
'RX5 MIX1 INP1':0:RX1
'RX5 MIX1 INP2':0:RX2
'LINEOUT2 Volume':1:100%
'LINEOUT4 Volume':1:100%
'RX5 Digital Volume':1:65%

The exact line you want to edit is
'RX5 Digital Volume':1:65%

Only change the percentage amount, and only change it in small increments
  • Do you have a custom kernel? Do you have the s-tweaks app? Some kernels let you change these settings easily through a GUI. Alternatively you may have to install CyanogenMod DSP or Viper4Android or such. I know you don't want to but it's a possibility. Also nightlies have tons of bugs so you can't rely on them as a daily driver (as I'm sure you know).
    – RossC
    Jan 21, 2015 at 14:36
  • @RossC: I don't have custom kernel, just ordinary cm. I don't have s-tweaks app. Before I posted this question I did some search and reading the found that " CyanogenMod DSP" usually did not help. Then I found the code above and thought that that's generic solution to my issue....
    – Radek
    Jan 21, 2015 at 22:36
  • Just in case, have you tried using something like viper4android? It has inbuilt function to increase volume gain from system's limits. Instead of editing system files you can try using that too (since its only louder volume output that matters right?) And make sure you install other sound effect controllers like DSP first. May 31, 2015 at 7:57

1 Answer 1


I'm thinking your phone is codenamed "evita" and the file you're looking at is here. Maybe you could try kicking up those ":1:73"s to ":1:78" or another small increment, restart, and see if it's any louder. If so, raise the number from 78 to 83 or whatever until you find the volume you like.

You can compare with this change for mako (Nexus 4) and this comment as well... You might also Google for "msm8960 volume" to see recommendatiosn for other devices that use your qualcomm system-on-a-chip.

I don't know for sure if this will work as expected, but you can report back and let me know if it does.

  • That's the question what I need to change. All '73's to something else?
    – Radek
    Jan 22, 2015 at 9:06
  • 1
    Yes I would start there. I don't know if it's the Digital Volume or Lineout Volume that matters, but you can change them both (or in pairs) to see if it makes a difference. If you are running CyanogenMod nightlies with root shell, try adb shell, then su, then mount -o rw,remount /system (to put /system in read/write mode) and then nano /system/etc/snd_soc_msm_2x and edit and save the change directly to the device. Then reboot to see if it works.
    – fattire
    Jan 22, 2015 at 9:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .