1

I have Nexus 7 (Android 4.4.4) and got message:

System update downloaded Android 5.0.2 System Update

But when I press on it, nothing happens.

How can I install this update?

UPDATE: About Tablet screenshot:

enter image description here

2

I had the same problem on my Nexus 7 (2012) on 4.4.4.

Do you have multiple user accounts on your tablet? If so, have you tried installing the update from the other account(s)?

I have two accounts, and when the 5.0.2 update got pushed to my device, both accounts got the notification. However, one of them had the same symptoms you described -- nothing happened when I pressed the notification, and the settings app didn't say anything about the update. From the other account, the update worked.

Strangely, the account that worked was not the one I created when I setup the tablet.

1
  • yes, it worked, installed from other account. – Alexan Jan 18 '15 at 16:03
0

On your Nexus tablet go to:

  1. All Apps
  2. Settings
  3. About Tablet
  4. System Updates

This should take you to a screen that tells you that you have a system update downloaded, and it should have the option to "Restart and Install".

6
  • I don't have System Updates there – Alexan Jan 15 '15 at 17:44
  • @Alex, have you done anything weird to the tablet? Rooted it? Unlocked it? etc? I'm not sure why "System Updates" wouldn't be on that menu. – New-To-IT Jan 15 '15 at 17:49
  • no, did nothing – Alexan Jan 15 '15 at 18:01
  • Sorry if you have, but have you tried restarting the tablet? – New-To-IT Jan 15 '15 at 18:01
  • yes, restarted several times – Alexan Jan 15 '15 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.