3

This is a very strange problem, so I'm sorry if I describe in in a confusing way.

For the past few days, I've been playing around with NFC on my Oneplus One phone. I installed a few apps (NXP TagInfo and Trigger, most notably), and they work fine. I wrote a simple app to scan and display the ID of a tag. This was all working fine with the NFC tags I have lying around (Tag inside a water bottle: NfcV. Other tags: NfcA (I think). They're unmarked, and this is all I know about them).

But suddenly a problem started: One tag, which is inside of a water bottle, scans fine. But the other two tags I have don't. When I try to scan them, they 'break' the NFC on the phone, and it becomes unable to scan the water bottle. I have to turn NFC off and on again to fix it, at which point it scans the water bottle just fine. This problem is very consistent.

I have a Nexus 4 which was able to scan all of the above tags and display the ID, but not read or write the actual data on the tag. My Oneplus is able to read and write data to the tag in the water bottle.

I don't understand what could possibly be causing this. As I previously mentioned, the tags worked just fine earlier. I haven't updated the phone or made any significant changes over the past few days.

Phone: Oneplus One, rooted, running CyanogenMod 11S (The stock software the phone shipped with)

3

This is normal1 behavior. The Android NFC stack is known to die when the communication with tags is interrupted during certain communication phases. So what you are experiencing is a poor transmission between the phone and the tag. In those cases where the communication between the phone and the tag drops in the "wrong" moment, the NFC service dies and you have to manually restart it by disabling & re-enabling NFC from the settings app.



1) Read "normal" as "you have to accept that things are like this" but not as "this is intended/bugfree behavior".

  • OMG, you saved me with this, my OPO's NFC stack crapped out and I couldn't write to any tag anymore, and I tried rebooting, clearing the data of the NFC applications, clearing the data of the NFC service and nothing worked, I didn't think of disabling/enabling. – Didi Kohen Nov 24 '15 at 6:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.