9

There is a pesky bloatware app (specificlly VUDU Version 1.0) that came preinstalled on my device. Whenever I boot my device, it starts up an app process, so every time I boot I have to open up the App Switcher and swipe it away.

I went into the Settings app and tried to Force Stop and then Disable the app, but the Disable button is disabled ("greyed-out") itself. Some other apps also don't allow me to disable them. Is there any other way that I can enable the button or disable the app without rooting? I am running 4.4.2.

4

Sorry, but you have to root in order to do this. There is no other way.

  1. Root

  2. (optional) Install Titanium Backup and backup your phone. If you mess something up you can restore your phone using this

  3. Now use an app called System App Remover to select the app you want to delete. You will have to grant superuser permission for it to work

  • Alright, thank you for your reply. I don't think I will be rooting because my device is brand new but I appreciate the information. – Xyspade Jan 16 '15 at 3:38
7

On some Android versions you can use adb to disable apps that you would otherwise not be able to deactivate via the UI. The Debloater app linked to above automates and simplifies this process. This answer will explain how to perform the same process manually.

WARNING: Disabling the wrong app or using the wrong commands can leave your device soft-bricked. Please make sure you know what you are doing before proceeding.

  1. Make sure you've got Android debugging set up correctly, then drop into an adb shell:

    adb shell
    
  2. Get a list of all installed packages by using pm

    pm list packages -f
    
  3. Identify the packages you want to disable and make a note of them.

  4. Disable each package individually by running one of the following commands:

    • if you are on Kitkat: pm block <package_name>, e.g. pm block com.motorola.motocare
    • if you are on Lollipop: pm hide <package_name>, e.g. pm hide com.motorola.motocare
  5. The app should now be disabled and disappear from your launcher. In case of a background service it will permanently stop running in the background.

To reverse this procedure you can use one of the following commands:

  • if you are on Kitkat: pm unblock <package_name>, e.g. pm unblock com.motorola.motocare
  • if you are on Lollipop: pm unhide <package_name>, e.g. pm unhide com.motorola.motocare
  • 1
    For completion sake, since Android M and onwards, you can still disable OEM bloatware by running: pm uninstall -k --user 0 <name of package> without root access. But beware, the changes are permanent unless you perform a factory reset in which case the bloatware will be installed again. – Prahlad Yeri Aug 24 '18 at 15:02
2

Yes, there is another way :)

You are lucky because you have Android Kitkat version. Just use tool Debloater by Gatesjunior from XDA: http://forum.xda-developers.com/android/software/debloater-remove-carrier-bloat-t2998294

Requirements: The program requires that your manufacturer USB drivers are installed for your specific device as well as the following: • Windows Operating System • USB Debugging turned on for your device • Root or KitKat running on your device

  • I tried your way and downloaded the program, but it is not recognizing my device. I went through all the steps and turned on USB Debugging. My tablet is RCA brand, and upon further research, it seems that RCA does not produce drivers for their devices. Can I still use this program some other way? – Xyspade Jan 23 '15 at 17:56
  • Your manufacturer USB drivers for your specific device is mandatory requirement. Try to find out help on XDA with USB driver for your device. What exactly type is your device? RCA brand tablet isn't so much helpful information if you need a help ;) – jis Jan 23 '15 at 23:07
  • What exact information would be helpful to you, like the model number? – Xyspade Feb 1 '15 at 1:16
  • Post here everything what you can about your device. For example I have phone Motorola Moto G LTE, but exact information is model number on its paper box: XT1039. – jis Feb 1 '15 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.