1

So a few days ago I finally looked out for a custom ROM avaible for my Xiaomi Mi3 td. I found an Android 5 Lollipop ROM (by ivan) and thought that I test it and maybe look for some bugs. So far so good, but after installing cwm and flashing the ROM I couldn't use the recovery anymore. It just showed me that broken (red) android logo.

First I tried to flash to stock rom with MiFlash (software from xiaomi to flash roms - like odin for samsung), but my phone was not recognized by MIflash. So I tried adb. "adb devices" doesn't show anything! The only good thing is, that I can still use the Android 5 (aosp) rom, but it's full of bugs I can't do anything. All debugging things are working (usb debug, the mtp is working too)! But only if my phone is booted in the system.

2

I might have misinterpreted your question, but to enable ADB to list Xiaomi devices, you need to update adb_usb.ini and put Xiaomi vendor IDs there:

  • On windows go to c:/Users/{your-username}/.android
  • On Linux ~/.android
  • Open the file adb_usb.ini in a text editor and add these three lines:

    0x8087
    0x2080
    0x2717
  • Save the file, open a CMD (or terminal) and enter the commands:

    adb kill-server 
    adb start-server 
  • Reconnect the device, type this in CMD, now it should be recognized.

    adb devices
    

Source here.

1

You can flash your device in Fastboot mode. Hold Power and Volume-Minus button, phone will enter Fastboot. Then connect it to the computer and use standard "fastboot" utility from Android SDK. This way you can reflash recovery partition (or any other partition) even if other modes are not working correctly.

Alternatively you can try to reinstall drivers while phone is in recovery mode. No special driver is needed when phone is working normally, because it acts like MTP device. When in recovery, it acts as ADB Interface, so you should install Google ADB drivers to make phone work while in recovery.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.