I periodically get this error on my phone. It will say the internal storage is running out but when I check the storage use it will say:

Total space 1.97 GB Available: 182MB Apps: 622 MB Cached 11.70 MB

This time, I checked my android/data folder and it said Spotify was using 1GB of space (in addition to all the space it is using in my other storage), so I deleted the Spotify cache and uninstalled it, then wiped my cache in recovery, but I didn't end up with any extra space afterwards.

I've deleted the log and LOST.DIR folders.

I can't seem to free up any more space. Every time this happens I have to factory reset and reinstall cyanogen (I'm running CM 10.1.3 now) to recover storage space, but each time it happens again eventually. I tried updating to a newer version of CM 10.1.3 but that doesn't help either.

UPDATE: I went through my apps to see if there was data I could get rid of there. I found 268MB in my Twitter app cache, but when I tried to clear the cache it wouldn't move. I uninstalled twitter but it didn't free up any storage space...

What am I doing wrong?



1 Answer 1


Just so anyone reading this who's having trouble knows, I figured out the answer.

My phone has several data/log folders (for some reason), and definitely had saved dumpstate files to those locations before so I assumed that when they were empty that wasn't the issue. HOWEVER.

I thought I had looked everywhere on my phone, but using ES File Explorer, even with 'see hidden files' turned on, doesn't show you all the files on your device automatically. Turning on Superuser lets you view more files, and there was another data/log file full of 1GB of dumpstate files hidden in another folder. Deleting this sent my storage space back to normal.

So, if you've tried deleting log files with a file explorer app and it hasn't worked, check your settings, make sure your file explorer app has all the access permissions it needs, and look harder. They're probably there.

Knew I was doing something wrong! I had never read anything in existing answers saying that this might happen when you look through your phone with a file explorer app, so hopefully this helps someone who's still stuck (that or it was just me).


Not the answer you're looking for? Browse other questions tagged .