7

I have followed all the instructions from here and here for enabling kvm for android studio to enable vm acceleration.

Still I suspect that when I start android studio it isn't using kvm because on starting it, in the Run box at the bottom the command executed is

/root/Android/Sdk/tools/emulator -netdelay none -netspeed full -avd Nexus_5_API_21_x86

I don't see the -qemu -m 512 -enable-kvm option appended to it. Is there a way to check if it's actually using vm acceleration?

5

I just checked if the file /dev/kvm was opened before and after the emulator started:

sudo lsof -n | grep /dev/kvm
  • Good, but sudo is not needed. – Sacha K Jun 12 '16 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.