There is a semi-relevant thread on SO https://stackoverflow.com/questions/12640708/check-if-android-filesystem-is-encrypted that explains how a developer would determine if full-disk encryption is enabled, but is there an easy way for a user to know? I tried encrypting (I'm on 4.4.2) and it seemed to fail at some point but did not throw an error, just dropped me back to the homescreen at a certain point.

  • I haven't tried to encrypted my phone, but from other relevant questions, especially "How do I turn-off lockscreen on encrypted phone?", the answer is to check if you can turn-off/disable the lockscreen, since AFAIK, you need PIN/credential for encryption. (Might be moot if the user also installed user-certificate though) – Andrew T. Jan 17 '15 at 21:28
  • 1
    That's not conclusive (as you said), you can set a PIN without encryption – warsong Jan 17 '15 at 21:57
  • I have a Galaxy S6 that I attempted to encrypt, I started the process and took a shower. When I came back to check the results I could not tell if it was successful. The only difference is that there is no longer a choice to encrypt. That does not conclusively indicate that the phone is encrypted. – xjohndoe001x Doex Aug 27 '16 at 7:27

Same place where you start the encryption:

In (I am on 4.3) Settings -> Options -> Security, the first entry will report the status and offer decrypt (if encrypted) or encrypt (if not).

  • I could be wrong but isn't there a difference between FDE and system encryption? I think the one you mention is only system level. – warsong Aug 27 '16 at 12:07

On Oreo 8.0.0

Settings → Security & Location → Encryption & Credentials & it shows phone encrypted

Better method

Using command adb shell getprop ro.crypto.state ( works on unrooted devices also) returns encrypted or unencrypted

Output examples

  • Oreo ( Unrooted, encrypted)

Vostro1510 ~ $ adb shell getprop ro.crypto.state


  • Marshmallow ( Rooted, unencrypted)

Vostro1510 ~ $ adb shell getprop ro.crypto.state


Source - Adb command to check if the device is encrypted

Note : Original question refers to Full Disk Encryption which has been replaced by File encryption from Nougat onwards. See this for details

Edit Instead of adb you can install Termux and type getprop ro.crypto.state to get the result - works on unrooted device also


The best way to tell if your Android device is encrypted (and the encryption is actually in use) is to reboot it and see if it asks for a password/PIN with a prompt on a black screen that says:

To start Android, enter your PIN

If you're not seeing this prompt, then even though your device may be encrypted, the encryption is pretty much useless. This is because Android's encryption works in two steps:

  • your files* get encrypted with a 128-bit master key
  • the master key is either encrypted with your password or just stored as is

The lack of prompt means the master key is not encrypted (or your device is not encrypted at all) and your data could be read by anyone who manages to boot a recovery image on your device such as TWRP.

To enable the encryption (enabled by default on devices shipped with 5.0+) go to Settings > Security & location > Encryption & credentials > Encrypt phone.

But to actually have the master key encrypted and your files inaccessible without a password, you need to go to Settings > Security & location > Screen lock > PIN or Password and tap Yes when it asks if you want to use Secure start-up.

This is how settings look like on Oreo, other versions may be different, but the settings you're looking for should be pretty much the same.

*7.0+ encrypts files, Android 5.0 - 6.x encrypts partitions (source)


Try changeing default storage to SD Card

Settings -> Memory -> Default Location -> SD Card

if your phone is encrypted than you'll get a warning stating that internal memory is encrypted. Of course its only a hint, not a proof.

My P9 Lite (Android 7) behaves like that, and this is consistent with user guide page 193

Full-disk encryption | All data on the memory chipset is automatically encrypted

protected by Community Jan 7 at 15:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.