2
  • Device: OnePlus One
  • ROM: MultiROM with CM11s as internal, and CM12 nightly as secondary
  • Recovery: TWRP
  • Backup location: USB OTG
  • Backup method: Online Nandroid Backup application

So I have quite a dilemma on my hands. I wanted to try something, so I installed a root DPI changing app. I must have set it incorrectly because when I rebooted, everything was so large that I couldn't even unlock the device.

So I followed the application's advice, I copied the build.prop backup to /system. And I went into a boot loop. Then I tried copying the stock build.prop for my device to /system, but it didn't help any.

Everything else seems to work fine. I have TWRP installed, and I have a good backup, but it's on a USB drive, and the data partition is ~6.5GB, so it won't go back on my phone. So here are my options, as I see them:

  1. Fix build.prop, of which I don't have the original file.
    • Problems:
      • I have no idea how to do that.
  2. Restore from my TWRP backup.
    • Problems:
      • I have the backup on a USB drive.
      • TWRP doesn't seem to want to recognize that there is a backup on the USB OTG.
      • The data file is 6.94GB (over Android's 4GB file size limit), so I can't move it back.
  3. Dirty re-flash the OS while keeping my data.
    • Problems:
      • I don't know how to do that.
      • I've heard that problems persist if that's done.
  4. Wipe everything and start from scratch.
    • Problems:
      • Obviously, I don't want to do that.
1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – Andrew T.
    Jan 27, 2021 at 23:03

4 Answers 4

3

The reason for a boot loop after editing build.prop is its permissions.

Just go to TWRP > Advanced > File Manager and navigate to /system/build.prop. Select it and change its permissions to -rw-r--r--. To do that, enter 0644 in chmod and reboot your device.

If you cannot see build.prop in /system folder, go to Mounts and select System in the TWRP home menu.

1

Maybe this problem is solved but for future reference, I will post these two options:

  • Push the original build.prop via ADB when on TWRP
    1. Plug the device into your PC
    2. Open a CMD or a terminal (depends on your OS)
    3. Write this commands
      adb kill-server
      adb root
      adb remount
      adb push original-build.prop /system/build.prop
      

Or

  • Grab the current build.prop, edit the density, and then push it back
    1. Grab it by using adb pull /system/build.prop /path/to/build.prop
    2. Edit the build.prop
    3. Then push it back
      adb kill-server
      adb root
      adb remount
      adb push edited-build.prop /system/build.prop
      
1

If the build.prop is the problem, you could try fixing permissions:

  • Restore build.prop from backup
  • Go to TWRP/Advanced and choose Fix permissions

If you want to restore your TWRP backup:

  • In TWRP, do a factory reset
  • Boot up the system and copy the TWRP backup to the internal SD card (if you got enough space). That should be formatted with ext4 or something like that, not FAT32.
  • Boot to recovery and restore the backup.

or

  • Just reflash the ROM.zip. That should fix all problems without deleting /data.
0
0

So, I actually ended up flashing only the system.img and boot.img files, and that let the device turn on.

There were a few problems I ran into, though. Settings kept force quitting, for one thing. But I was able to make a fresh Helium backup, so then I wiped everything and started over. After spending a bit of time restoring some files, my One is running well again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .