2

I have installed and tried several of the "App Ops" starter apps from the Google Play store. When I run any of them, a dialog pops up saying "Unfortunately, Settings has stopped." and my only choice is to tap "OK". So, I still have not been able to get to the App Ops settings.

However, this app claims to work on 4.4.4.

I am running on the stock Moto G (2nd gen), Android version 4.4.4. Not rooted.

Are unrooted 4.4.4 users generally restricted from running App Ops or is there something wrong with my setup? If it is as simple as getting another app to run App Ops for me, can someone point to one that works in 4.4.4 without the error?

2

App Ops can be activated using Xposed Module, but for that you need to root your device. And an alternative to App Ops is XPrivacy.

0

App Ops can't be run without root privilege. If someone tell you the opposite, it is most likely a lie, or if it is real then the whole Android OS is worthless because what makes Android secure is the permissions. If you can bypass them with a regular app, then why bother making permissions?

  • Actually, it's not the app that I download that would do the work. The downloaded app is only a shortcut to a hidden settings app/activity already in Android. So I think App Ops already has privileges, like how the user can "force stop" an app without needing to be root. – user29020 Jan 19 '15 at 0:15
  • 1
    as from android 4.4.3 app ops has been removed by google and need root permission to be used cnet.com/news/why-android-wont-be-getting-app-ops-anytime-soon – lord-ralf-adolf Jan 19 '15 at 17:57
0

Unrooted Verizon Note 3 user here. Not sure why, but App Ops Starter works for me on 4.4.4 even though it didn't on 4.4.2 (I think I had the same or a similar crash-out issue that you have described).

  • Hi, thanks. For some reason, though, the "App Ops Starter" just launches my standard Settings page where I would access all the normal system settings. No "app ops" anywhere to be seen. – user29020 Apr 5 '15 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.