On my Samsung Galaxy S4, the "Calendar" under "Sync settings" in my Google account disappeared. Under the Google accounts at the bottom, it reads

Sync is currently experiencing problems. It will be back shortly.

How do I fix it?

  • In my case there was a problem with emoji characters in some names. I used "Contacts Sync Fix" program to fix it
    – ssasa
    Commented Mar 13, 2017 at 21:05
  • The phone wasn't connected to the internet. As soon as it was syncing worked. You'd think the error message would be better than the generic one "Sync is currently experiencing problems. It will be back shortly" Commented Feb 9, 2018 at 8:04
  • Samsung Galaxy S9 exchange calendar sync not working anymore: Error message (in Settings -> Cloud and accounts -> Accounts -> <Exchange account> -> Sync account): 'Sync is currently experincing problems. It will be back shortly.' Go to Settings -> Cloud and accounts -> Accounts -> <Exchange account> -> Account settings. Click on your <Exchange account> -> (scroll all the way down) Server Settings -> Incoming settings. Enter new password. Click done. Wait for success message. Go back to 'Sync account' and hit Sync Calendar, Sync Contacts, Sync Mail. Commented Nov 19, 2018 at 9:43
  • Try to take a look at this website, seems reasonable up to date: appuals.com/fix-sync-is-currently-experiencing-problems
    – SeF
    Commented Feb 6, 2019 at 11:41
  • FWIW: in my case I had to set up PIN protection to make it work because my "company policy required it". Of course there was no helpful error message about it :( Sidenote: I can't reply to this thread b/c of lack of karma or something Commented Apr 22, 2021 at 15:44

13 Answers 13


Not closely related to the issue, but it solved my very similar problem with contacts sync: The contact option was not listed in Android's (v.6.0.1, Marshmallow) Settings / Accounts / Google sync menu. The problem was that the Contacts Sync application had no access right to my contacts. To fix this, I switched the Settings / Apps / Gear icon / App permissions / Contacts / Google Contacts Sync toggle. After that, it started to sync, but I got the same 'Sync is currently experiencing problems'. It turned out that I exceeded the Google API call limit for the day, so after 24 hours, it synced successfully.

To figure out what the problem exactly was, I connected my phone through USB to my PC, enabled debugging on the phone, used the adb logcat command from the Android SDK, and examined the errors/exceptions in that log. This way, you can get to the bottom of your calendar issue as well.


We had the same problem, and to make a long story short, tried all the answers we found online (clear cache, clear data, reinstall Calendar, delete, then create Google account, but no factory reset).

The problem for this phone (Samsung Galaxy S3) was that we had restricted background data on Google Play Services. Once that was enabled, the calendar synced right away.

Home> Settings> Connections> Data Usage> Scroll down to Google Play Services, and make sure to uncheck "restrict background data".

  • The answer for me was related to Google Play Services. But in my case it was a matter of enabling its permission to access Contacts. Settings->Apps->Google Play Services->Permissions->Contacts Commented Apr 10, 2018 at 10:05
  • Settings->Apps->Google Play Services->Permissions->Contacts -> Enable for Google Play Services worked for me. Commented Aug 8, 2018 at 16:13
  • In my case, the sync issue was with the WhatsApp account. I went to the app permissions and checked some of them. Worked. Commented May 28, 2019 at 2:20
  • In my case, the solution was Settings>Apps>Google Play services>Storage>Manage Storage>Clear All Data. Commented Nov 18, 2021 at 4:07

I tried EVERYTHING. Finally came across the answer - turned off Power Saving (which I normally keep my phone on) and hey presto, everything syncs again. So easy.

  • Turning off power saving Setting>Account>Google> (Top right) Sync now. Works for me. Thanks
    – user197105
    Commented Nov 19, 2016 at 6:43
  • Solved My Problem with this Account>Google>Sync Now. Thanks. Commented Jan 16, 2017 at 8:51

Sync is currently experiencing problems. It will be back shortly.

Go to Settings → Accounts → Exchange → Incoming Settings and change the security type to SSL/TLS from SSL/TLS (accept all certificates) and there you go. All the emails, contact, calender will start syncing.


I fixed this by installing Google Calendar. I already had Calendar installed, from gapps (needed with CyanogenMod). Now I have two Calendar apps installed, both called the same thing. Sync suddenly works, and the new calendar has a bit nicer UI.

  • I had both the standard Calendar and Google Calendar installed, and the fix for me was disabling my Google Calendar sync in the standard Calendar app.
    – drudge
    Commented Sep 11, 2016 at 16:22
  • Installing Google Calendar fixed the sync issue, and both S Planner and Google Calendar suddenly started working.
    – Sampo
    Commented Oct 18, 2017 at 7:14

In my case, ONLY the contacts didn't sync, everything else (calendar etc.) was fine, but the steps should apply to calendar as well, as it also uses dedicated services and the play store.

I followed this guide and got it working perfectly again, without loosing any data or having to restore anything.

Cannot sync contacts on Android 11 - This account already exists on your device

It links to a few pictures of the Android UI, but the short version is:

Prereqs.: Uninstall Battery Saver / Task killer / Booster Apps temporarily,

  • Reset App Preferences
  • Select Automatic Time Zone
  • Battery Saver select off
  • Remove Battery optimization for Google Contacts Sync
  • Allow Mobile Data usage for Google Contacts Sync (the obvious part)
  • Select Contacts Permissions for Google Play services and Google Play store (the tricky part)
  • Clear Data in Contacts and Google Contacts Sync (the scary part)
  • Disable Google Contacts Sync and wait a minute and Enable Google Contacts Sync
  • Re-start device (essential!)
  • Check sync settings.

According to the logs from adb logcat the permissions actually caused the problem, but all previous attemtpts to grant those permissions failed.
After following this step by step, I rebooted, opened the Contacts app and was able to add the already signed in google user. After that, the contacts got populated and sync works again.


In my case, the error was with my Samsung account on my GS4. When I pressed 'Profile' underneath the sync option, it prompted me to install an update which may have been the cause. When I pressed 'Yes' it failed to update. However, once I restarted the phone the update successfully installed.

For anyone with this problem, I would advise restarting your phone, then (for Samsung accounts), go to Settings > Accounts > Samsung account > Profile

Install the update if prompted. Lastly make sure Sync is enabled in the notifications bar.


I had the same problems and finally was able to fix it.

I always try to use my phone on power saving mode to save battery, after the last update I had some troubles with that feature because many apps don't work properly. Well, all I had to do was disable power mode and sync again and voila, everything sync perfectly.

I hope this helps.


Just adding to the pool of possibilities.... Make sure your date/time is correct. All I had to do was adjust it and everything went back to normal.


I had a similar problem, but with Contacts instead of Calendar. It turned out that all I had to do was to force stop (Settings -> Apps -> Contacts -> Force stop) the Contacts app and start it again.


If your device is rooted then delete the folder under /data/data/com.android.providers.calendar and reboot. (I used Total Commander.)

For problems with contacts sync the folder is /data/data/com.android.providers.settings.

In brought back the sync on my device which has been constantly "experiencing problems" for about half a year.


To sum up my fix:

I checked my online Google Calendar settings to ensure mobile syncing was active. It was.

On my Samsung Galaxy S4, I uninstalled Google Calendar & re-installed it a couple of times. Still kept receiving the syncing message.

So I removed my Google account & reconnected. That's when I received the message "The process android.process.acore has stopped".

Based on users' comments, the best fix would be to reset to factory. Which I did and all is good except for losing SMS history

  • 1
    You could have used SMS backup apps to backup your SMS messages to Google drive.
    – Lucky
    Commented Nov 5, 2015 at 16:18

I have just had the same problem after an Android upgrade on my Sony Xperia Z5 and luckily fixed it. I had to delete the account and then re-add it.

I think I know why this worked as I have seen a similar problem before (with Dropbox about 2 upgrades ago): with this new Android version, a new security feature was added and Exchange couldn't automatically access my calendar/contacts -> it wasn't allowed.

When you re-add the account, you are asked if Exchange is allowed to access contacts and calendars. Once you say "yes", all works.

I really think Android needs to handle the addition of new security features to existing apps in a more elegant manner.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .