12

Android S4 my "Calendar" under "Sync settings" in my Google account disappeared. Under the Google accounts at the bottom it reads "Sync is currently experiencing problems. It will be back shortly" How do I fix?

  • 2
    As it says "will be back shortly": Wait a little? For how long is your device in this state already? – Izzy Jan 18 '15 at 11:08
  • It was over 15 hours. Than I received a message "The process android.process.acore has stopped. With that, based on users comments I factory re-set my device. Everything is working fine now...Thank you – Carmel Jan 19 '15 at 15:51
  • Glad to read you've solved your issue! As on SE sites it's perfectly fine to answer your own question: Mind to sum up your steps (like taking your comment, and fill some gaps) in an answer? That might help other users who might experiences a similar issue. Thanks a lot! – Izzy Jan 19 '15 at 16:48
  • To sum up my fix. Checked my on-line google calendar settings to ensure mobile syncing was active. It was. On my Samsung S4 I uninstalled google calendar & re-installed a couple of times. Still kept receiving the syncing message. So I removed my google account & reconnected. That's when I received the message "The process android.process.acore has stopped. Based on users comments the best fix would be to reset to factory. Which I did and all is good except for losing SMS history – Carmel Jan 20 '15 at 18:21
  • Carmel, you should use the Answer box below. Otherwise the problem is still marked open/unanswered as it has no "answer". I could copy that for you, but then I'd get the credits belonging to you :) – Izzy Jan 20 '15 at 19:23

12 Answers 12

7

We had the same problem, and to make a long story short, tried all the answers we found online (clear cache, clear data, reinstall Calendar, delete, then create Google account, but no factory reset).

The problem for this phone (Samsung Galaxy S3) was that we had restricted background data on Google Play Services. Once that was enabled, the calendar synced right away.

Home> Settings> Connections> Data Usage> Scroll down to Google Play Services, and make sure to uncheck "restrict background data".

  • The answer for me was related to Google Play Services. But in my case it was a matter of enabling its permission to access Contacts. Settings->Apps->Google Play Services->Permissions->Contacts – Tom Russell Apr 10 '18 at 10:05
  • Settings->Apps->Google Play Services->Permissions->Contacts -> Enable for Google Play Services worked for me. – alansiqueira27 Aug 8 '18 at 16:13
  • In my case, the sync issue was with the WhatsApp account. I went to the app permissions and checked some of them. Worked. – Carlos Pinzón May 28 at 2:20
6

Not closely related to the issue, but it solved my very similar problem with contacts sync:

Contact option was not listed in Android's (v.6.0.1, Marshmallow) Settings / Accounts / Google sync menu.

The problem was that the Contacts Sync application had no access right to my contacts.

To fix this, I switched the Settings / Apps / Gear icon / App permissions / Contacts / Google Contacts Sync toggle.

After that it started to sync, but I got the same 'Sync is currently experiencing problems'.

It turned out that I exceeded the Google API call limit for the day, so after 24 hours it synced successfully.

To figure out what the problem exactly was I connected my phone through USB to my PC, enabled debugging on the phone, used the adb logcat command from the Android SDK and examined the errors/exceptions in that log. This way you can get to the bottom of your calendar issue as well.

4

I tried EVERYTHING. Finally came across the answer - turned off Power Saving (which I normally keep my phone on) and hey presto, everything syncs again. So easy.

  • Turning off power saving Setting>Account>Google> (Top right) Sync now. Works for me. Thanks – user197105 Nov 19 '16 at 6:43
  • Solved My Problem with this Account>Google>Sync Now. Thanks. – Mandar Pandit Jan 16 '17 at 8:51
  • 1
    I'm surprised the error message doesn't tell you to do this. – kmoser Mar 10 '17 at 5:40
1

Sync is currently experiencing problems. It will be back shortly.

Go to Settings → Accounts → Exchange → Incoming Settings and change the security type to SSL/TLS from SSL/TLS (accept all certificates) and there you go. All the emails, contact, calender will start syncing.

1

I fixed this by installing Google Calendar. I already had Calendar installed, from gapps (needed with CyanogenMod). Now I have two Calendar apps installed, both called the same thing. Sync suddenly works, and the new calendar has a bit nicer UI.

  • I had both the standard Calendar and Google Calendar installed, and the fix for me was disabling my Google Calendar sync in the standard Calendar app. – drudge Sep 11 '16 at 16:22
  • Installing Google Calendar fixed the sync issue, and both S Planner and Google Calendar suddenly started working. – Sampo Oct 18 '17 at 7:14
0

To sum up my fix. Checked my on-line google calendar settings to ensure mobile syncing was active. It was. On my Samsung S4 I uninstalled google calendar & re-installed a couple of times. Still kept receiving the syncing message. So I removed my google account & reconnected. That's when I received the message "The process android.process.acore has stopped". Based on users comments the best fix would be to reset to factory. Which I did and all is good except for losing SMS history

  • 1
    You could have used SMS backup apps to backup your SMS messages to Google drive. – Lucky Nov 5 '15 at 16:18
  • You should check this answer as correct if it was what solved the problem for you. – HelloGoodbye Feb 15 '16 at 7:32
0

In my case, the error was with my Samsung account on my GS4. When I pressed 'Profile' underneath the sync option, it prompted me to install an update which may have been the cause. When I pressed 'Yes' it failed to update. However, once I restarted the phone the update successfully installed.

For anyone with this problem, I would advise restarting your phone, then (for Samsung accounts), go to Settings > Accounts > Samsung account > Profile

Install the update if prompted. Lastly make sure Sync is enabled in the notifications bar.

0

I have just had the same problem after an android upgrade on my sony xperia Z5. And luckily fixed it. I had to delete the account and then re-add it. I think I know why this worked as I have seen a similar problem before (with dropbox about 2 upgrades ago): with this new android version a new security feature was added and exchange couldn't automatically access my calendar/contacts -> it wasn't allowed. When you re-add the account you are asked if exchange is allowed to access contacts and calendar. Once you say "yes" all works. I really think android needs to handle the addition of new security features to existing apps in a more elegant manner.

0

I had the same problems and finally was able to fix it.

I always try to use my phone on power saving mode to save battery, after the last update I had some troubles with that feature because many apps don't work properly. Well, all I had to do was disable power mode and sync again and voila, everything sync perfectly.

I hope this helps.

0

Just adding to the pool of possibilities.... Make sure your date/time is correct. All I had to do was adjust it and everything went back to normal.

0

I had a similar problem, but with Contacts instead of Calendar. It turned out that all I had to do was to force stop (Settings -> Apps -> Contacts -> Force stop) the Contacts app and start it again.

0

If your device is rooted then delete the folder under /data/data/com.android.providers.calendar and reboot. (I used Total Commander.)

For problems with contacts sync the folder is /data/data/com.android.providers.settings.

In brought back the sync on my device which has been constantly "experiencing problems" for about half a year.

protected by Matthew Read Nov 19 '16 at 17:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.