I just installed Cyanogenmod on my Samsung Galaxy Note. Before doing so I created a backup with adb:

adb backup -all

For some of my apps I want to restore settings. Most importantly that would be K-9 Mail. Thus I unpacked the backup:

java -jar android-backup-extractor-20140630-bin/abe.jar unpack backup.ab backup.tar

Then I deleted most folders which I don't want to restore but I did not delete apps/apps/com.fsck.k9. Then I packed the file again using android back extractor and ran adb restore after I installed K-9 Mail. I was prompted for consent on my phone which I accepted and I was told that the restore was successful. However when I start K-9 Mail I am just greeted with the default welcome screen as if no configuration would be present. I also tried the same with WhatsApp and Viber but both showed the same behaviour.

Next I tried to just copy the k9 mail settings folder using USB connection using a file manager (dolphin). But still no success.

Then I tried to copy the settings using adb push apps/com.fsck.k9 /data/data/com.fsck.k9 (described by someone here) which failed with file or directory not found error. After further googling I tried again but ran adb root before and then that worked. However k9 still greets me with obviously no settings. Since the same source I googled for that idea stated something about a fix_permission script (where I have no idea where that comes from) I googled for fix_permission and found this app installed it and ran it. However still no change.

How is the restore done correctly?

1 Answer 1


OK, some googleing later I found Titanum Backup and that it supports restoring selectively from adb backups. I copied the backup to my SD-Card and then restored using Titanum Backup and and just worked. (However I'd still be interested in what I missed in the first place).

Note however that the free version does not support restore from adb files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .