This question already has an answer here:

I recently switched over from Eclipse ADT to Android Studio and as soon as I tried to fire up the emulator, I saw the following message:

emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!

On Googling around, I found that disabling Hyper-V would solve this problem. It did. And the emulator worked like a charm. But then, my internet stopped working. In any form. WiFi, Ethernet, every kind of service went bust. Re enabling Hyper-V restored my internet connection, but the error came back. So, I can either use the internet or my emulator.
I really can't keep doing that. Is there an alternate to this?

marked as duplicate by Matthew Read Apr 9 '16 at 20:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Wow, 20k views in 5 months and no answer? – Pacerier Jul 1 '15 at 13:39
  • @Pacerier it's a common issue, and yet, no fix has been found. Since then, I have been using my device/genymotion for development – Ranveer Jul 1 '15 at 13:43

You need to install Intel's HAXM module. HAXM accelerates your emulator so you don't test apps like a slideshow.

My advice: Install Intel HAXM. Leave Virtualization Acceleration functions (Hyper-V, Vt-X etc.) activated and the emulator will work. There seems to be something wrong with your network adapter/configuration, too. Virtualization should be independant from your network.

Also please read the error message first and do a Google search to make sure such questions aren't already answered.

  • 1
    I did install Intel HAXM. I still have the problem. Also, I did Google the issue, but didn't find anything apart from disabling Hyper-V – Ranveer Jan 18 '15 at 14:35
  • The error message "HAX kernel module is not installed!" makes me assume it's not installed. If Hyper-V is not used, it shouldn't cause any issues AFAIK. – GiantTree Jan 18 '15 at 14:38
  • 1
    So here's what I did. I disabled Hyper-V and installed HAXM. The emulator then worked. But re enabling Hyper-V gave this error message again. – Ranveer Jan 18 '15 at 14:40
  • 1
    Also, this is where I got the advice from: stackoverflow.com/a/18207178/2302611 – Ranveer Jan 18 '15 at 14:52
  • 1
    Well, in that case, I'll keep this question open. :/ – Ranveer Jan 18 '15 at 15:18

I solved this by creating a new Virtual Device in AVD Manager with API level above 14. Try using API level 15 or higher.

protected by Community Apr 6 '15 at 12:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.