Why I can't scan the Whatsapp QR?

  • I reinstalled WhatsApp
  • I already have the WhatsApp Web Option
  • I put it to scan but it just doesn't scan it.
  • I Installed a QR Scanner app and it works perfectly.
  • I uninstalled the QR Scanner app to see if that was the issue and still doesn't work.

My phone is a Samsung Galaxy Ace.

  • Is the problem that the page won't open, or that the app won't scan the QR at all? Have you tried a different scanning app? (I recommend Barcode Scanner.) – LyricWulf Jan 22 '15 at 5:26
  • 2
    Are you holding the device correctly enough for the QR scanner to work ! I somewhere doubt that this is still a new service which might be the reason why things are going a little out of the.... – Peter Carlos Jan 22 '15 at 5:41
  • I am having Sony live with walkman, and also I can't able to scan the code, beside that NeoReader is able to scan the code easily. On scanning the code, it shows some of the garbage text(might a be a session cookie or signature to verify the account). If anyone is facing the same problem and have any workaround for that, Please post here. . . .. – Rohit Prakash Jan 22 '15 at 6:50
  • Well, you don't need to look for the third part QR code scanners rather than the QR scanner can be found on the whatsapp itself. I think people are getting problem because they are installing third party QR code scanners. Open the Whatsapp>Menu>Whats app Web – Peter Carlos Jan 22 '15 at 7:38
  • ***** My problem was in an adware called "Superfish" that came with my brand new Lenovo Y50. I removed it and got the QR right away. – Adam Tal Feb 15 '15 at 18:04
up vote 10 down vote accepted

SOLUTION

Okay, first of all - you have to scan the QR-Code with the scanner that is built in WhatsApp. Not with some 3rd-party scanner-app. Click on "Whatsapp Web", then the scanner opens immediately.

BUT - apparently there is a problem with devices that have a display smaller than 4 inches!

Like with my Sony Xperia Go (3,5 inches), I can't tap on the "OK, got it"-button to make the instructions of the built-in-scanner go away.

That's it. They will have to solve this problem in a later version, I guess.

  • 2
    Yes! Thank you! That's it! I can't see the "Ok, got it" on my screen. Thank you all! – DesignNae Jan 22 '15 at 14:37
  • If you are root user and you install xposed framework, then you'll be able to install a module for executing apps in smaller size. I did that on a friend's phone and I could see the ok, got it message – Joaquin Iurchuk Jan 23 '15 at 3:58
  • It seems there is a new update that fixed this issue based on this answer on other post: version 2.11.505 – Andrew T. Jan 23 '15 at 9:22
  • new update released by Whatsapp !! now its working :) – agpt Jan 23 '15 at 13:06

Turn off WiFi.

Apparently, WhatsApp only connects itself to the web session if it's online via mobile data.

  • 2
    That was it. I've now tried turning off and on WiFi several times - it immediately works when on LTE, it never works on WiFi. Funny thing is that WhatsApp itself suggests "Connect through wifi to reduce your data traffic". So I disabled WiFi, scanned the code, re-enabled the WiFi and now it works. The only explanation I can find is that it is using some service to map my LTE IP back to my phone number. I'll try later from another phone, connected with WiFi first to my home ADSL, then to my phone's LTE network. If it works, and with the former only, that will clinch it. Meanwhile, +1. – LSerni Apr 4 '17 at 18:11
  • 1
    You would think that the WhatsApp app should tell you this when trying to scan a QR code. – mydoghasworms May 11 at 8:15

protected by Community Jan 22 '15 at 12:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.