1

I am a first time Android user. I just got an LG G3 at AT&T. Being comforatable with unix/linux based systems I quickly rooted the phone and installed a few different ROMs looking for one that worked.

I settled on pa_d850-4.6-BETA6-20141130 which seems to work really well except for one huge problem: my phone doesn't show up on my PC as an MTP device. It DOES show up as a camera when using PTP. And I can use adp commands from my windows PC.

One strage problem is that my LG G3 shows up under Windows 7 (Ultimate x64) device manager as "Computer->Android Device->Google Nexus ADB Interface" (rather than an LG G3) when connected as both MTP and PTP. Is this a common problem and if so, how can I get my phone to show up as an MTP device?

1

I have experienced this issue myself and it was because when you plug the phone in the first time, windows automatically tries to locate drivers and by default uses the Google Nexus ADB Interface.

If you go to the LG website support section you can specifically download the LG G3 drivers and install those instead. I would recommend removing the existing entry from the device list first (phone unplugged) and then running the LG drivers and plugging your phone back in afterwards.

This fixed the issue for me and now whichever option (MTP, PTP and debug mode) all work properly.

  • Worked. I had to uninstall the drivers for both PTP and MTP. – Sponge Bob Jan 31 '15 at 2:26
  • Glad this worked for you! They never tell you when you get a new phone that you should install their own drivers first to get full functionality! – Matt_Roberts Feb 2 '15 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.