OK some background here. I was running CM 11 nightly on Nexus 7 (2013) and had encrypted my device. Today i decided to flash my device to CM12 and hence went into recovery. When I tried to do a clean wipe it gave me errors because my data is encrypted. I did some research on google and I found this solution to it. I don't know what came to my mind but for some reason I ran this command without thinking much. mke2fs -t ext4 /dev/block/mmcblk0p12 This snippet is from the link given above. I usually never do something foolish like this without enough research. Now my device mounts on the PC as if it's an external drive rather than a tab. I can see all the partitions mounted when I connect it to the PC. It won't boot into recovery or bootloader. Am lost. Can someone please guide me as to what are the probable solutions to this?

When I opened GParted and saw the partitions of my device it shows that no partition table exists. I think that's what the main issue is. Can someone guide me as to what I can do to restore or rebuild the partition table?


You must log in to answer this question.

Browse other questions tagged .