0

My play store used to be the US version and just a few days back it changed to Hong Kong version. Now I cannot figure out why and how it changed and I want to get it back to US version.

The only thing I can recall is that I used a proxy of HK those days. But now no matter how I set the proxy, my tablet, phone and the web page always give me the HK version.

I have read the posts about activating the play store of another country after relocate and I tried the methods, until now none of them works.

My account has two credit cards added, one's address is in US and the other is in Canada. Two of my apps that are only available in North America are not shown in neither [INSTALLED] nor in [ALL APPS] now.

The webpage version would show the US version as long as I logout my account, otherwise the HK version. The visible paid apps are all in HKD currency, which is rather disturbing!

Someone, please help me!

===UPDATE ON FEB 27, 2015===

The play store still shows HK version, however if I view games that are distributed to non-NA region (like EA's pvz_row, or r3_row) in the web page, it shows "The app is not supported in your device's country). Yet if I download a na version, the in-app-purchase currency shows HKD prices. I am confused, maybe I will have to contact Google play support team.

3
  • Well, log onto the Google account which you are using over your device, head over to the google account settings and tap over the "language" and change language variant to "US" or the one you want ! Jan 23 '15 at 7:28
  • Thank you for the point, but the language setting is already like that.
    – Qianqian
    Jan 23 '15 at 7:33
  • now that's weird ! I think I ran out of options over here maybe you should wait a little while and see if anyone over our community can help you in guiding with the same ! Jan 23 '15 at 8:22
0

Clearing app data and cache of Google Play Store worked for me.

0

Try clearing your data of Google play Store and your Chrome browser and then put your phone's location on. Then go into chrome and accept the "chrome would like to use your location" (or something along those lines) and sign into your Google account. This fixed my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.