0

My new Nexus 6 isn't giving me an LTE icon in my cell service - I get the same old H that was showing on my Nexus 4 before I upgraded.

I'd expect to see LTE here : Top bar

I talked to my carrier, who said that my data plan includes LTE, so I don't think that's a problem.

I've tried to set LTE as my preferred network, but it won't take. I go to:

Settings -> Wireless/More -> Cellular networks -> Preferred network type

choose LTE (recommended)

But the Preferred network type remains on 3G after I make the change.

Is there some other setting I'm missing that will enable LTE? I've power cycled the phone several times and run through every fix I can imagine. I'm on Android 5.0.1 with AT&T.

  • Are you sure you get 4G in your area? Just because 4G is part of your plan, and your phone supports it, if you don't have 4G towers in your area, you won't get 4G signal. – New-To-IT Jan 23 '15 at 21:34
  • Yeah, I'm downtown in a major city where everyone else gets the 4G network. – eouw0o83hf Jan 24 '15 at 0:31
  • Check LTE frecuency bands acepted for your phone, perhaps your phone's LTE bands are diferente from those usted by att I your local area. I have the same problem so I check compatibily at frequencycheck.com – user162371 Apr 23 '16 at 0:06
1

Chances are most likely that the SIM card you are using is not LTE enabled. You can check with the service provider on upgrading the SIM.

Once the SIM is upgraded, install Open Signal application in the phone and test for 4G signal coverage.

0

Just in case anyone else runs into this issue: I went into an AT&T device location where they replaced my SIM card with a new one. After that, LTE was immediately available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.