MOTO G 2nd gen, Mobile data not working (India) post Android Upgrade to 5.0.2 from 4.4.4...any clue..

could be linked to improper upgrade and is there a way to restore ??

  • If your problem is solved, mark the answer as accepted, this removes the need to modify the question title.
    – bmdixon
    Jan 29, 2015 at 16:40

2 Answers 2


Weirdly I inserted another sim into the 2nd slot(it has no service btw), and voila The excalamtion(!) mark is gone from the mobile network icon and Mobile data is back up. I just hope XDA doo take a look at this... And yes I had tried soft reset , factory reset, re inserting the sim and re registering , APN manual config etc etc..

  • Well, great that looks like you need to reinsert the SIM and SD card once you did the update ! Now you can mark your question as solved I would say. Jan 28, 2015 at 10:07
  • I had actually reinserted the single sim alone but that dint work, when i reinserted the sim along with the sim in the other slot it worked. Another bug i notice is that you can independently turn off mobile data for one sim, turning it off for one turns it off overall(wonder if its just me). Jan 28, 2015 at 11:29

My issue has been solved, I have changed my sim slot it is working now. Previously I was using slot-2 for my sim so it was not connected to the internet, now I changed it to slot-1 the exclamatory mark has disappeared and the internet is working now.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .