1

The 5.0.2 OTA update soft-bricked my rooted but otherwise stock Nexus 7. I tried several times to wipe/reset from recovery, but it kept boot-looping afterwards. After a hundred tries or so was finally able to connect via adb to my Mac and sideload the update. Booted up fine after the update but of course all my data is now gone.

Problem is that now I cannot seem to get any adb connection over usb so that I can re-root and restore my backups. I am hoping this isn't a hardware problem as my device is a year-and-a-half old. Maybe someone can confirm it's likely hardware related, or even better has a solution that I haven't tried yet.

Here is a list of everything I've tried to resolve the issue.

1) Cable/ports - I am using the stock asus USB cable that came with the tablet. It powers the device just fine. When I connect my Nexus 5 with the same cable, then adb works perfectly from my Mac (2009 MBP w/ USB 2.0, Yosemite 10.10.1). I have tried another USB cable with the same result. I have tried all 3 of the USB ports on my MBP with same result. Running system_profiler SPUSBDataType from the Mac terminal doesn't show the N7 (but it does show the N5).

2) Windows - I don't have a Windows computer, but I do have Win7 running on VirtualBox. I have the same connectivity issue there, the WugFresh NRT recognizes my N5 but not my N7.

3) Settings - I have disabled/re-enabled USB in Developer Options several times to no effect. I also toggled the MTP/PTP connection options on and off (I keep them off as I transfer files using AirDroid in lieu of the crappy AFT).

4) adb - From Terminal Emulator running on my N7, I have killed and started the adb server several times. I can't use adb tcpip (wifi) without the device being rooted.

At a complete loss here and really don't want to replace my N7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.