0

So i connect my USB to my phone and computer as usual. my phone vibrates and starts charging but my computer doesn't show my device in the my computer section.the USB symbol that appears on the top left of my phone isn't there as well. My PC doesn't make that beeping sound which means it connected. USB debugging mode didn't seem to do anything. i didn't find it in the device manager. uninstalling/re-installing the Samsung drivers didn't seem to fix this issue. Usually I use my Logitech cable, so i thought that might be the issue and I tried using the cable my S4 came with but it's still the same - nothing. Any suggestions on how I may be able to fix this? i would be very grateful. Thank you for your time.

  • Try to change the USB connection to PTP (camera) mode if available. Also, check the device manager and see if there's a problem (a yellow warning icon) – Andrew T. Jan 29 '15 at 5:37
  • i changed it to PTP and its still the same - PC still can't see it. I checked the decie manager and theres no warning/alerts of any kind. but thank you for your input. – Dan Casey Delaon Jan 29 '15 at 7:10
  • Try yet another cable. Also the connector on the phone can be damaged. A low-level usb debugging on the PC side could be useful. Any chance booting Linux on that box? If so, you can use dmesg to monitor any USB changes to see if the phone at least tries to communicate. – mikky Jan 30 '15 at 10:46
  • Have you tried it on a different USB port? Different PC altogether? – Chahk Feb 2 '15 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.