6

I'm unable to customize the ringtone on my second generation Moto G after upgrading to Lollipop. I tried doing it normally from the Android settings, but just got a default "beep" sound instead. Only the built-in ringtone works properly.

  • Well, that's weird ! Haven't heard anything like this from the members over here even I am also having the same Moto G2 and things are working just fine with me ! Means you are the only one having this problem may be you should backup your data and try performing a complete factory reset ! – Peter Carlos Jan 30 '15 at 10:18
  • 1
    You may want to look at the answers here, if you have not already: Custom ringtone not working on Nexus 5 since OTA Lollipop – eldarerathis Jan 30 '15 at 15:02
  • 2
    I am facing the same problem in MOTO G Gen2. After upgrading to Lollipop, custom ringtone stopped working (If you assign tone to particualr contact, its working, but phone ringtone is not working...) everything else is fine. Please guide me if there is any solution for this. – Santhosh Feb 12 '15 at 5:29
  • Work around for this is here: Convert ur mp3 files to .ogg files and set as ringtone. audio.online-convert.com/convert-to-ogg – Santhosh Feb 16 '15 at 10:46
  • 1
    @AkiRoss, .ogg file works as ringtone. Convert your mp3 to .ogg and set as ringtone. If you don't want to convert to .ogg, try to set a ringtone from file explorer. i.e Install and open ES File Explorer - sdcard - <whatever folder> - open your mp3 file in ES media player - set as ringtone using player options. – Santhosh Jul 8 '15 at 8:04
2

Someone put this as an edit instead of an answer:

Instead of setting ringtone under setting --> Sounds and notifications, try to set your ringtone from your player [Ex: ES File Explorer --> sdcard --> download --> your song. Play this in ES media player --> set ringtone ].

and someone else tried to edit this in:

1- change ur choice music into .ogg format (try fx file explorer it may able to rename any format u want)
2- put that music file on the ringtone folder on phone where hangout ringtones are present 3-now power off ur phone and start it
4-go to phones and notification folder u got ur choice music as a ringtone

  • I just tried by moving my required song to device storage, then saved that song in ringtone folder present in sd card folder and set the song as ringtone via file explorer and it worked. – Reshma Aug 11 '15 at 7:51
1

Please Try this way, Simply Place the Your Ringtone in FileExplorer-->sdcard-->Ringtones-->yourRingTone file.Its working.

0

I have the same problem here's how I solve the problem.

Copy the song you want to set as ringtone to your internal memory / ringtones folder and set it as your ringtone. Note setting ringtone from sd card won't work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.