1

I updated my HTC One m8 to Lollipop and rooted it. I have programs that require the ability to write to external SD card like FileMount, but every time I launch FileMount it tells me that it can't write to SD card. The app itself has a feature to enable it automatically but it requires a reboot but still even after reboot the same problem occurs.

When I was on android 4.4.4 I tried installing sd fix but that thing didn't work. I installed Xposed installer and installed HandleExternalStorage module and it worked great for me. But I can't use Xposed installer on Lollipop as the developer says it might not be possible for Xposed installer to be available for Lollipop. My device is 16 GB only and it's really not enough for me and I rely on FileMount for my storage issues.

2

Try applying the SD fix manually, the details are over at XDA. The steps are:

  1. Remount the system partition as read+write (use an app such as ES File Explorer, or enter mount -o remount,rw /system after becoming root in a terminal).
  2. Make a backup of the /system/etc/permissions/platform.xml file, just to be sure.
  3. Look for the XML element android.permission.WRITE_EXTERNAL_STORAGE and make it look like this:

    <permission name=android.permission.WRITE_EXTERNAL_STORAGE >
    <group gid="sdcard_r" />
    <group gid="sdcard_rw" />
    <group gid="media_rw" />
    </permission>
    
  4. Similarly, find the XML element android.permission.WRITE_MEDIA_STORAGE and change it to:

    <permission name="android.permission.WRITE_MEDIA_STORAGE" >
    <group gid="sdcard_rw" />
    <group gid="media_rw" />
    </permission>
    
  5. Set the file permissions to rw-r--r--, either using a file explorer app, or by typing chmod /system/etc/permissions/platform.xml into a root terminal.

  6. Reboot the phone -- this is important for the phone to remount the storage.

All credit goes to poolmaker at XDA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.