After upgrading to Lollipop from 4.4.4, mobile data doesn't work. I have tried all the solutions listed in various forums including, 1. Reboot 2. Reboot after re-inserting the sim card. 3. Manually add the APN (Got the settings from the service provider) 4. Toggle between the Preferred Network type (2G and 3G)

I have only one usable sim slot, and so cannot use sim slot-1. I have heard it worked for a few guys after putting the sim in the other slot, but unfortunately I cannot try that out.

Any suggestions?


Okay, so here I am posting an answer to my own question. I finally visited a Motorola service center today to get the problem fixed and I was told that they are aware of the issue and that they'll be rolling out an update with a fix in 5 days. Hopefully everything will turn out well after that.

  • Just yesterday i got lollipop on my MotoG! I'm having same issue!! Its been 4 months since you posted the answer; Did the update roll out? Is your mobile data working? – Necktwi Jun 9 '15 at 11:05
  • @neckTwi: It looks like Rocks may never return. Did you ever find a solution to this issue which started affecting you more than a year ago? – unforgettableid Aug 21 '16 at 19:16

protected by Matthew Read Feb 8 '15 at 14:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.