3

I just updated my Moto G to Android Lollipop via official Motorola update. Now, my Moto G is not connecting to the my cellular Data Plan and not even identifying my home Wi-Fi. (Interestingly, the phone is connecting and identifying other Wi-Fi s)

Please suggest a solution.

  • Well, that gives me a feel that at the time of updating your device may have encountered some error as I am also having Moto G which has been recently updated with the Android Lollipop 5.0.2, and couldn't see the bug you are talking about, did you tried removing and re-inserting the SIM card, if not then try doing that because sometimes it do helps in fixing common problems like the one you are referring to and if by chance if you still don't get things back to working then I would say, most of the time it's better to perform a factory reset! See if that helps .... – Peter Carlos Feb 3 '15 at 9:10
  • 3
    Check your wifi channel on your home wifi router. If you have channel 12 or 13, then is probably your phone configured for bad region (e.g. us), just go to advanced settings in wifi settings and set the right region. – jis Feb 3 '15 at 23:04
  • 1
    I just resolved this issue on my wife's MotoG by changing the channel in wifi router to 6. You should choose your wifi channels based on some simple app like play.google.com/store/apps/… – pavanlimo May 30 '15 at 3:36
  • Added an answer as a comment since I could not add answer to this question even though I've the required reputation. :/ – pavanlimo May 30 '15 at 3:37

Browse other questions tagged or ask your own question.