5

Edit: Apparently this question was marked 'popular', so I thought I would mention that I found my solution, which has worked without issue: An app called DisableService which let me disable the Motorola OTA Update service. Root is required.

I've been trying to avoid my phone updating for about a week now. Every few minutes I'm switched away from whatever app I'm using to an update screen. Originally there was an option to update later, but now it's gone and I simply switch back to the app I was using. Obviously, this is quite disruptive. Unfortunately, I tapped the 'Okay' (something to that effect) button and now it's attempting to download the update in the background. I've been able to mitigate this by stopping the MotorolaOTA app, and disabling Wi-Fi.

I'll be clearing out all my Wi-Fi connections in case my phone connects to one and continues the update. I'll also see if I can introduce something which blocks the update servers.

How can I cancel this so I don't have to worry about the update completing? I have compatibility concerns.

How else can I battle this OTA terror? Please, you're my only hope!

I have a Motorola Moto G, XT1031.

Edit: I have multiple ideas. One is to, and I don't yet have extensive knowledge of how SSL certificate authorities work, but to introduce a custom root CA, with a CRL including the update server.

Cruder methods include: running a nameserver to use when on Wi-Fi, which blocks the update server, or a proxy/VPN which could filter requests. Maybe I could create a fake update server which says, "all good, no updates" and make my phone talk to it with a custom root CA certificate.

1

Disabling Motorola OTA should do the job. Just go to the Apps section in your Android preferences and find the Motorola OTA entry under the 'All' tab. Disable it from there and you shouldn't get any more update prompts.

(Click image to enlarge)

IMG:

  • Unfortunately, my phone prevents me from disabling it. I don't have root permissions. But if the Disable button were not grayed out, yes, that would likely work! – Austin Burk Feb 5 '15 at 12:33
  • That's strange. Unrooted here and it works. Might be a provider-specific restriction? – Glutanimate Feb 5 '15 at 12:53
  • 2
    I don't know, but I've finally given up, my provider is complaining about how I'm only using 3G and no Wi-Fi. – Austin Burk Feb 8 '15 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.