I was implementing reverse-tethering using Samsung galaxy fit and ubuntu 10.10
I have followed the following post for the procedure: How to browse Internet in Samsung Galaxy Fit using Broadband in Windows 7?

I am using a DSL connection(BroadBand) and upon running

sudo ifconfig eth01

I got

SIOCSIFADDR: No such device

so i renamed the DSL connection to eth0 ,then it worked fine.

The main Problem occured in implementing the third step: on running

./adb shell netcfg usb0 dhcp

I got error:

device not found

Usb tethering on the Mobile is on. The Mobile is new and I have not much with it.


3 Answers 3


I am trying to do the same thing on my Samsung Captivate (Galaxy S) with no success. I have followed this tutorial: http://blog.mycila.com/2010/06/reverse-usb-tethering-with-android-22.html

And I think that the problem is, and may also be for you, that "tethering and Usb debugging don't work simultaneously on this device". Bummer.


The instructions for USB Networking Replicant are here. Replicant is a Free Software-Only fork of CyanogenMod, so it's more or less a rooted Android.

(It's entirely possible that USB networking requires root, as Replicant ships with root out of the box.)

I've done similar steps on other phones running Linux (OpenMoko FreeRunner). The scripts on the host PC is for Linux users, so it's not as applicable to your question as I'd like, but it's something.

Short version, on phone:

echo 1 > /sys/class/usb_composite/rndis/enable
ifconfig usb0 up

As of note, this may require busybox pushed to your phone, which is common in rooted environments.


After running the following command:

sudo ./adb shell netcfg usb0 dhcp or
./adb shell netcfg usb0 dhcp 

I get:

action 'dhcp' failed (Permission denied)

I think this is because the phone needs to be rooted, aka it is not possible to have reverse-tethering without rooting, at least not on Samsung Galaxy. If I'm wrong (and I hope so), please correct me.

  • "Permission denied" can also act like "command not found" on Android. There's no distinction between the two in the default shell shipped with Android.
    – Broam
    Commented Aug 4, 2011 at 14:17
  • Well I don't care too much weather I don't have the permissions or the command is not available. By the way I think the command is there because if I run: sudo ./adb shell netcfg I get all network interfaces listed. So what I care is: why is Step 4 of the tutorial not working for me? Step 4 is: ./adb shell netcfg usb0 dhcp For me it fails with following error: action 'dhcp' failed (Permission denied) My hypothesis is that step 4 fails for me because it is not rooted. So if someone knows that this is not true, please correct me. Luca
    – Luca
    Commented Aug 4, 2011 at 14:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .