1

I have a Moto G first gen,

Post the lollipop update the operator data is NOT working. Its just WiFi which is working. What I have done: Updated to Lollipop - Thru WiFi Checked - Operator Data Not Working

Solutions which I did, which was recieved from Google Plus community & Moto Care Agent (Live Chat) 1. Cleared Cache 2. Did a soft reset & rebooted With Sim & Without Sim 3. Did a hard reset & rebooted with Sim & Without SIM

PS: My first SIM slot is tampered & not working. I just have the SIM 2 which is working.

  • 1
    "Moto G first gen" / "I just have the SIM 2" - Only the Moto G 2nd gen has 2 SIM card slots? – MrWhite Feb 6 '15 at 11:50

12 Answers 12

1

Check your APN settings : Settings -> wireless & networks -> more -> cellular networks -> access point names.

Theses settings are provided by your operator, or you'll easily find them by internet.

  • This didn't help..Checked the APN settings re installed the APN too. – Nitin CR Feb 20 '15 at 9:44
1

I have just upgraded my Samsung to OS 5.0.2 and lost my mobile data. All other features are still working. I have a dual SIM phone and I was able to resolve this by going to the SIM management settings and changing the setup to use the SIM active SIM slot and the upgrade led the phone to use the empty slot for the data. I hope that you will find this useful

0

I'm sure you've already sorted it out, but in case someone else has the same problem,

I struggled to get access to mobile internet myself, and what helped, was deleting all the other APN profiles and leaving just the needed one. After reset, it got back to normal.

0

With Lollipop upgrade, you systematically lose the 3G or 4G configuration! All you have to do is call your operator provider. They will send you an SMS with new settings for APN. Doing this fixed my problem.

  • Nothing of the above said worked, i went to the local repair shop and got the SIM 1 fixed, post which the internet started to work on SIM 1 slot. Till date SIM 2 slot for net is not working – Nitin CR Apr 30 '15 at 4:48
0

Go to sim card manager(on Samsung) and select the sim you want to use data of from the data service network. It should start working again.

0

I also faced the similar problem. This simple change in settings did the trick:

Go to Settings → SIM Card manager → Data service network → Select the SIM 1 or SIM 2 depending on your choice for the data network.

0

I'm with T-Mobile (US) and had a similar issue. I resolved it by updating the APN information as per T-Mobile instructions.

  • 1
    Welcome to Android Enthusiasts! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Otherwise, your answer becomes useless in case the link dies. For further hints, please see: How do I write a good answer. – bmdixon Jul 20 '15 at 9:08
0

I just found an answer to this.

I had inserted another sim on the vacant sim slot and the data services started. After removing the same sim now, the mobile data services is working perfectly.

So just borrow another sim for 5 mins and do this. Hopefully it'll work this way

0

I have just installed a custom (nameless) rom on my samsung note 2 and ecountered this issue (mobile network/internet not working even though I have just recently recharged)

The solution for me was like this: Settings -> Mobile Network -> Access Point Names

I changed from Zain BH WAP to Zain BH Internet.

I expect this solution to work for all other operators / ISPs.

-1

My solution: enable flight mode, then disable it. It worked for me.

-1

I found an easy way. Go to Settings -> Mobile Settings -> APN -> Restore to default

this will solve it.

-1

I Uninstalled Updates on Google+
SettingsAppsGoogle+Uninstall updates

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.