2

In my mobile phone (CyanogenMod 11-M12, Galaxy SIII I9300), in WiFi section my WiFi SSID is shown and under its name is Save, secured with WPA/WPA2. WiFi is ON. If I press SSID, a pop-up ask me to Cancel, Forget or Connect. and if I press Connect no connection is established!

I was connecting to this SSID without any problem before this. It seems that this problem occurred after installing "Google Apps" or after changing some privacy setting in Privacy Guard section. But I did not remember changing any system application's privacy settings, I just limited Google Apps privacy access.

Update 1:

I tried Factory Reset from recovery mode. It solved the problem, but after few hours of working with the device, the problem repeated. After that, Factory Reset did not solved the problem. I tried reinstalling CM from zip file. I installed CM11 zip file and did wipe (Cache, System, Internal Storage) partitions from recovery, but the problem persists. In the second try, I did wipe (Cache, System, Data, Internal Storage) partition and installed CM zip file after that. This solved the problem. But I am not sure if the problem will occur again or not?

Update 2:

The problem occurred after a while again, it seems that the problem occurs after installing some Google Apps!

  • When you try to connect what is displayed in the status ? Something like "connecting..." then "getting IP Address" or nothing at all ? – Christ-OFF Feb 6 '15 at 9:30
  • @ChtiSuisse Nothing at all! – PHP Learner Feb 6 '15 at 10:10
  • I Tried entering wrong password for the SSID, but ot does not changes any thing. It seems that the device does try to connect to WiFi network, so it does differ if I enter correct password or wrong one! – PHP Learner Feb 6 '15 at 11:04
  • Where you get the selection "Cancel/Forget/Connect", try "Forget". Then wait until the entry is updated, and this time chose "Connect". You should be asked for the credentials again, provide them. Does this enable you to establish a connection? If not: Any message this time? What about signal strength? – Izzy Feb 6 '15 at 16:55
  • @Izzy I tried "Forget" and creating new connection (system finds my SSID again and asks me for password). But it seems that it does not even try to connect to my SSID. Because if I enter wrong password there will be no difference! – PHP Learner Feb 6 '15 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.